Support » Themes and Templates » FF sidebar links display as text only

  • Hi. I just noticed that in Firefox, the links in my sidebar are just text but in IE they are fine–links w/ hovers, etc. I’m new enough to wordpress that I have no idea where to start troubleshooting. Anyone have any ideas?
    I’m using the dixiebelle theme, the address is

Viewing 9 replies - 1 through 9 (of 9 total)
  • To tell you the sad story, the theme seems to be made with only MSIE in mind. It has to do with the way the styling is set up in the theme’s CSS Stylesheet.

    In Firefox 1.5 on Windows, where I can test it, the post are overlapping the titles and links on the left side, making only half of it readable. And even worse, you cannot click on the links to get anywhere.

    You should consider changing the theme or dig in to your Stylesheet.

    can you tell me how the mods i’ve made to the theme look to you? i think i’ve got everything looking good as far as the layout goes (except this major problem with the sidebar links)

    hopefully all the time i’ve spent getting it right won’t have to just be scrapped…

    check it out here:

    FF 1.0.7 on Win – none of the links in your sidebar work.

    thanks–any ideas on whether this might be a php/wordpress issue or a css problem?

    this is weird–if you click on the “about” page, the top 5 sidebar links don’t work, but all the others do. it seems kind of random…

    No of course not. You have a floating design and when I look at your site now, I see a big smiling image to the right.
    It doesn’t fit in my fairly large browser window and it pushes the main content area over your left sidebar.

    When I resize my window to something smaller, the smiling guy disappears behind the main content.

    I can still not click on any links to the left.
    In MSIE, when resizing, the guy is creeping under and the left sidebar covers some of the main content. The links are clickable.

    Don’t give up though. It is a clean, nice and funny design and you should take a deep breath, get some coffee or whatever you fancy and then start over.

    Get both browsers to test with, and try to get the different parts of your design not to overlap. This is done by tuning your Stylesheet.

    The dead links in Firefox may be caused by the overlapping problem. If one transparent ( invisible ) part of the main content overlaps the links, it is no longer possible to activate them.

    If you have Internet Explorer, get Firefox now, and vv.
    Good luck!

    boy, if that’s the links problem with ff (and it seems probable, based on how you describe it) and I have to figure out the other layout issues, maybe i’ll just have to break down and hire somebody who knows what they’re doing. i’ve been tweaking the layout css for hours now…

    or if i feel ambitious maybe i could get it to work with a three-column design that i remove the right column on. then change all the colors, etc. but then most templates don’t scroll just the content like this one. i don’t know–but this really sucks. thanks for the moral support, though–and for figuring out the problem.

    ok–if anyone checks this website for a bit, you probably see something different than described above, as I’ve had some orange juice and set to messing with the css again. I did determine that it was a layout issue causing ff not to make the links clickable. i was using a padding setting to adjust the placement of the content and when i changed that to margin setting, the links were fine. it just messed up the layout completely in ie.

    Looks nice now also in FF. Did you have that smiling image in the background before? As it is now ( see post date ), the image doesn’t overlap your categories and blogroll links and they work in all window widths.
    At 800 x 600 the little guy creeps *under* the link, but I can buy that.

    Smiling site!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘FF sidebar links display as text only’ is closed to new replies.