Support » Plugin: WP Scripts & Styles Optimizer » Fetching scripts and styles disables all styles on front end

  • Resolved joycegrace

    (@joycegrace)


    Hi there:

    • PHP Version 5.6
    • Genesis theme and framework
    • WP updated
    • No cache – testing on WP Engine staging site

    Something is up with the way this plugin interacts with my theme. I realize it may not be your fault. However, for the life of me I can’t seem to get to the bottom of why there may be a conflict. I’m hoping you may be able to shed a bit of light to help me out?

    Description of the situation and steps to reproduce:

    • Install and activate plugin
    • Navigate to and click on “Get/Update Global Scrips and Styles”
    • Scripts and styles are generated on the WP admin dashboard page
    • Front end looses all styling – it looks like a plain html page with no images and zero resources
    • “View source” shows all scripts and styles, and correctly registers or de-registers resources based on conditions set, even though front end doesn’t display anything but plain text links and plain text
    • No conditions need to be set for styling to go away, as mentioned above – simply click on “Get/Update Global Scrips and Styles” and the front end site is stripped down
    • Setting conditions doesn’t change anything
    • Clicking on “delete global lists” brings back front end styling
    • Deactivating all other plugins doesn’t change these results

    I tried setting up a debug log file using these instructions: https://codex.wordpress.org/Debugging_in_WordPress
    –> No debug file is generated when I try to reproduce this issue, which makes it hard for me to find the problem. Does that mean no official error?

    It must be in the theme, but I don’t even know where to look or what to test. Have you encountered this before? Any clues as to why it would do this?

    I’d be happy to share a link or screenshots if it can be done so privately?

    Thank you so much for your help.

    • This topic was modified 1 year, 7 months ago by  joycegrace.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Hendrik Lersch

    (@riddler84)

    Sry for the late answer and thank you for this very detailed description of your problem. But unfortunately i don’t know how i can help you with this problem.

    The Genesis framework is premium, so i can’t test it. But in general my plugin should work with any theme, as long the theme uses the native wordpress functions to load its scripts & styles (wp_enqueue_scripts and wp_enqueue_styles). After a little research i found out, that Genesis maybe echoes some of its scripts directly into the wp_head respectively the wp_footer hook. I’m not sure about that.

    My plugin couldn’t process these scripts, BUT it should be no problem.. normally.

    The part that confuse me is, that you say all scripts and styles are in the source code, but the site is completely unstyled. Sounds like the main CSS file is missing. Have you checked this? And is this file listed in the styles list after you click on the “get” button in backend?

    Hi thanks for the help here. This turned out to be an ssl issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fetching scripts and styles disables all styles on front end’ is closed to new replies.