WordPress.org

Forums

WP RSS Multi Importer
[resolved] Fetch Quantity Setting Issue (9 posts)

  1. viralbanter
    Member
    Posted 2 years ago #

    Allen,

    First off thank you for creating this tool. I am learning how to use it still but there seems to be plenty of options.

    I have 3 issues. One I solved with a workaround, 1 with another plug-in AutoTagger, and 1 I would consider a bug.

    1.Tab=Feed to Posts Settings -> Fetch Quantity Settings -> "Number of Total Post Entries per Fetch (should be much greater than the number of entries per feed)" is limiting the number of posts for the TOTAL NUMBER of posts instead of the total number of posts PER FEED.

    2.I am getting an "unsuccessful file tranfer" error for the images.
    wp-content/uploads/2013/02/12525-thumb-120x134.jpg
    This error is leaving the posts as "Scheduled" status.
    There is a large list of posts. I checked the permissions on the folders and they are wide open to the admin. These images are not getting uploaded for some reason.

    3.You may not be able to solve this one, but the AutoTagger plug-in was working with wp-o-matic to tag posts and is not automatically tagging the posts that come from WP RSS Multi Importer.

    I have 3 feeds setup right now for testing this plug-in.
    http://feeds.feedburner.com/thr/news
    http://feeds.sciencedaily.com/sciencedaily/most_popular
    http://feeds.feedburner.com/RSSMicro/Top_News

    The setting that seems to matter are the number of articles I am pulling for each, 5.
    The image setting, Feature Image.
    The Standard Template.

    Any help you can offer is appreciated.

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

  2. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,
    I just took your 3 feeds and set them for 5 items each for a total of 15 items...you can see the result here:

    http://www.wprssimporter.com/blog/

    I also checked and saw the images were becoming featured images, which they should since I checked that box.

    Are you on a development server? I ask because it appears the error you're getting is due to a server configuration.

  3. viralbanter
    Member
    Posted 2 years ago #

    I am not using a development server. This page is live at the moment with godaddy. I checked your link and it appears items 2 and 3 are overlapping but otherwise there are images. I am able to get some of the images to come through as well after changing some options from default then changing them back.

    Interesting that you are not getting errors. I have errors on 11 of the 15 posts. Here are the first 2 images that are erroring and their details from the queue.

    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-120x134.jpg wp-content/uploads/2013/02/12753-thumb-120x134.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-200x224.jpg wp-content/uploads/2013/02/12753-thumb-200x224.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-300x336.jpg wp-content/uploads/2013/02/12753-thumb-300x336.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-420x365.jpg wp-content/uploads/2013/02/12753-thumb-420x365.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-300x168.jpg wp-content/uploads/2013/02/12753-thumb-300x168.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb-150x150.jpg wp-content/uploads/2013/02/12753-thumb-150x150.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12753-thumb.jpg wp-content/uploads/2013/02/12753-thumb.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-120x134.jpg wp-content/uploads/2013/02/12751-thumb-120x134.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-200x224.jpg wp-content/uploads/2013/02/12751-thumb-200x224.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-300x336.jpg wp-content/uploads/2013/02/12751-thumb-300x336.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-420x365.jpg wp-content/uploads/2013/02/12751-thumb-420x365.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-300x168.jpg wp-content/uploads/2013/02/12751-thumb-300x168.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb-150x150.jpg wp-content/uploads/2013/02/12751-thumb-150x150.jpg Empty host. 2013-02-21 14:25:03 Delete
    /home/content/87/10366087/html/viralbanter/wp-content/uploads/2013/02/12751-thumb.jpg wp-content/uploads/2013/02/12751-thumb.jpg Empty host. 2013-02-21 14:25:03 Delete

  4. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Ok.....try going into Google and search for

    wordpress "empty host" error

    You'll see a lot of posts about W3 Total Cache and other possible sources of your problems..especially CDN related issues.

  5. viralbanter
    Member
    Posted 2 years ago #

    I disabled W3 Total Cache and the issue seems have subsided. Looks like there is a conflict that I will either have to resolve or go without W3 Total Cache. Very smart of you Allen. Thank you, I offer my praise!

    Again, I love the flexibility of the RSS tools!

    Oh, the AutoTagger was not broken, the posts were going into suspended status because of the timezone difference. Once I set the timezone correctly in the FEED TO POST SETTINGS, the posts became PUBLISHED and the AutoTagger did its job!

    Last but not least...

    Any thoughts on number issue #1?

  6. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    yes, set the Number of Entries per Feed to Fetch to 5 and the Number of Total Post Entries per Fetch to 15...I did that and got 5 items from each of 3 feeds.

  7. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Did this solve the problem?

  8. viralbanter
    Member
    Posted 2 years ago #

    Sure did! All set. I'm impressed to get the follow up. Again, I love this plugin. I'm still learning how to make it work the best, but it is fun.

    A suggestion for future development. I have a widget that functions exclusively on tags. It would be cool if I could indicate a specific tag to each feed as it is pulled.

    Also, it would be cool if I could choose how many posts are pulled from each feed individually. Example would be feed 1 pull ony the first 2 posts. Feed 2 pull 10 posts. Etc...

    Thank you for following up!

    -Derek

  9. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    Right now you can use a shortcode parameter to pull n number of posts from each feed (look at the shortcode parameters page).

    [wp_rss_multi_importer thisfeed="5"]

    As for tags, you can put tags on each feed, but it works at the category level (so you'd need to specify a feed for each category)..just go to the Categories page and you can see how you enter tags for each category.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP RSS Multi Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic