Support » Plugin: Flexible Elementor Panel » FEP exit button opens new tab, even when option is disabled

  • Resolved petercopenhagen

    (@petercopenhagen)


    Hi there

    I love FEP! But in the newest version it keeps opening a new tab whenever I press the FEP Exit button – even though I’ve disabled that option in FEP settings. It’s extremely annoying. Could you please fix this?

    FEP settings as follows
    Exit point: Edition
    Open in new tab: Off

    Setup as follows
    WordPress 5.3.2
    Elementor 2.9.0
    Elementor Pro 2.8.3
    FEP 2.0.0

    Thanks in advance.

    Best regards
    Peter

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author WebMat

    (@webmatpro)

    Hello Peter,

    i m sorry to listen about that.

    I m tried it and on multiple website, the option work correctly.

    Can you try again with change the others options to know if they will saved correctly, thanks.

    Hi WebMat

    The problem remain the same, sadly.

    I’ve tried the following:
    – changed all options in FEP, and then also back again
    – turned off all plugins for caching, security and CDN
    – flushed DNS in Windows 10
    – tried Firefox instead of Chrome

    Same problem.

    If anybody have any suggestions, they will be highly appreciated.

    Best regards
    Peter

    Plugin Author WebMat

    (@webmatpro)

    Aie 🙁

    Can you check your console developper ?

    Then when you will change the option, FEP will call a action in jQuery then change the “target” in the html code.

    When option is on:
    <a id="fep-exit" target="_blank" href="https://localhost/wordpress/?page_id=42" class="fep-exit-link elementor-panel-footer-tool elementor-leave-open fep-tooltip" original-title="Quitter"><i class="fa fa-sign-out"></i></a>

    When option is off:
    <a id="fep-exit" target="_self" href="https://localhost/wordpress/?page_id=42" title="Quitter" class="fep-exit-link elementor-panel-footer-tool elementor-leave-open fep-tooltip"><i class="fa fa-sign-out"></i></a>

    Hi

    I’m not really super techy, so I don’t know how to do, what you suggest. Do you have any documentation as how to do it?

    Hi arline2016

    Thanks for your input, appreciate it.

    I’ve tried changing settings as you mention. No luck.

    Since I don’t have the time for further troubleshooting, I chose to uninstall FEP. So now instead of hitting FEP’s Exit button, I hit Esc and then Elementor’s Back to admin. No big deal. And anyway, Elementor now allows you to go with a Dark UI (which was one of the reasons, I chose FEP). So that’s it. One less plugin to deal with. Thanks for the ride FEP 🙂

    Best regards
    Peter

    Plugin Author WebMat

    (@webmatpro)

    Hi @petercopenhagen

    i m sad to hear that.

    The operation of the options changes is done in jQuery in FEP.

    There is bound to be a javascript conflict.

    You can debug this way on chrome:

    1 – Open a page with the Elementor editor
    2 – Inspect errors on the page https://developers.google.com/web/tools/chrome-devtools/open
    3 – Then try to modify the options in FEP
    4 – If errors occur, you will have them in the console in red

    • This reply was modified 9 months, 2 weeks ago by WebMat.
    • This reply was modified 9 months, 2 weeks ago by WebMat.
    Plugin Author WebMat

    (@webmatpro)

    The new update version 2.1.1 fix all issue due in saving options.

    Let’s me know if everything okay,

    Thanks everyone.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘FEP exit button opens new tab, even when option is disabled’ is closed to new replies.