WordPress.org

Forums

Antispam Bee
[resolved] Fehler: Bitte gib einen Kommentar ein. (10 posts)

  1. twalbert
    Member
    Posted 12 months ago #

    Hallo Sergej,

    erst mal Respekt vor deiner Arbeit! Deine Plugins sind wirklich TOP!

    Allerdings habe ich aktuell ein Problem mit Antispam Bee.
    Beim Erstellen eines Kommentars wird die Meldung "Fehler: Bitte gib einen Kommentar ein." angezeigt, obwohl natürlich ein Kommentar eingegeben wurde.

    Ich habe den Fehler natürlich bereits recherchiert und bin auf diverse Beiträge gestoßen, die exakt das Problem beschreiben, aber schon 1-2 Jahre alt sind. Die dort beschriebenen Lösungen (Löschen den Plugins und erneuter Download+Upload+install) haben leider keine Besserung gebracht. Nur das Deaktivieren des Plugins löst das Problem umgehend.

    Da stellt sich natürlich die Frage, wie kann ein Problem, dass vor 2 Jahren schon gelöst wurde jetzt wieder auftreten? (ich benutze WP 3.9 und die neueste Plugin-Version.)
    Nachdem du dich damals ja wahrsch. schon intensiv mit dem Problem befasst hast, hast du bestimmt einen Lösungsansatz für mich, oder?

    Vielen Dank im Voraus!

    Beste Grüße
    Tobias

    https://wordpress.org/plugins/antispam-bee/

  2. apocalyarts
    Member
    Posted 10 months ago #

    Ich habe das identische Problem. Gibt es dazu inzwischen eine Lösung?

  3. twalbert
    Member
    Posted 10 months ago #

    Ich habe keine Lösung gefunden und musste das Plugin deaktivieren/deinstallieren.

  4. apocalyarts
    Member
    Posted 10 months ago #

    Sieht so aus als ist der Fehler auch in der neuen Version 2.60 vorhanden.

  5. oleo
    Member
    Posted 8 months ago #

    Bei mir hat geholfen, das Plugin zu löschen und wieder neu zu installieren.

  6. Caspar
    Member
    Posted 8 months ago #

    @all Tritt das Verhalten im Zusammenhang mit anderen Plugins auf? Um andere Plugins als Fehlerquelle auszuschließen, am besten mal alle außer ASB deaktivieren. Dann der Reihe nach wieder aktivieren und jedes Mal checken, ob der Fehler auftritt.

    Das Aktivieren des DEBUG-Modus könnte ebenfalls Erkenntnisse bringen.

    --

    @Mod Since this thread was started in German and a number of ppl replied I answered in German. Subject is an unexpected message “Error: Please enter a comment” when a comment is submitted.

  7. apocalyarts
    Member
    Posted 6 months ago #

    Habe mal alle Plugins deaktiviert und der Fehler trat nach wie vor auf.

    Edit: It looks like it is a theme issue. I will do some investigation...

  8. apocalyarts
    Member
    Posted 6 months ago #

    So it looks like I solved the problem with the message "Error: please enter a comment". As I wrote before, it looks like it is a template issue.

    In your template, check the comments.php. Make sure that the form is echoed via the comment_form() function from wordpress.

    In my case there was some legacy code because the editor from my template decided to hardcode the form with some jQuery-magic in there.

  9. Ov3rfly
    Member
    Posted 5 months ago #

    In your template, check the comments.php. Make sure that the form is echoed via the comment_form() function from wordpress

    Or try to add <?php do_action('comment_form', $post->ID); ?> within the hardcoded <form> ... </form>, does this help?

  10. Caspar
    Member
    Posted 5 months ago #

    @apocalyarts Correct, apparently there needs to be a `<textarea name="comment"> for ASB to work.

Reply

You must log in to post.

About this Plugin

  • Antispam Bee
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags