Support » Plugin: PayPal Plus for WooCommerce » Fehler bei Installation

  • Resolved jakoblieser

    (@jakoblieser)


    Hallo,
    bei dem Versuch das PayPal Plus Plugin zu installieren crasht die Website. Folgenden Fehler bekomme ich in den Php ErrorLogfiles angezeigt:
    [Wed May 23 19:06:08 2018] [php7:error] [pid 29145] [client 2003:e7::] [host melflair.de] PHP Fatal error: Access level to WCPayPalPlus\\WC\\PayPalPlusGateway::can_refund_order() must be public (as in class WC_Payment_Gateway) in /is/htdocs/wp12665440_E3YPSSJKWG/www/wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php on line 648

    Woran könnte das Problem liegen?
    Grüße

    The page I need help with: [log in to see the link]

Viewing 12 replies - 16 through 27 (of 27 total)
  • Danke – Meine Internetseite ist nun total lahmgelegt….

    Hallo Christina, danke für die Infos, bei mir hat das mit der Änderung in Zeile 283 funktioniert.

    Viele Grüße, Matthias.

    Hallo Christina,

    der Fix hat für mich funktioniert. Danke!!

    Vielen Dank Fix funktioniert!

    Fix hat auch bei mir funktioniert!

    Wir haben soeben ein neues Release veröffentlicht mit dem oben erwähnten Fix.

    Vielen Dank für eure Hilfe und eure Geduld.

    @vanvox Hallo alle zusammen.
    Haben das gleiche Problem seit heute früh, aber dank dem Vorschlag von Christina Fuchs läuft unsere Seite jetzt wieder.
    Müssen wir irgendwas beachten wenn das Update kommt? Die php eventuell wieder umschreiben?

    LG Blowshop

    @blowshop

    nein, updaten reicht aus. Die Datei wird dann mit der aus dem Update überschrieben. Und der Fix ist da drin.

    Schöne Grüße

    Hey Christina, bei mir steht das Ganze in Zeile 296. Der Fix hat aber geklappt, zumindest komme ich jetzt wieder auf die Seite 😉 Nun stellt sich die Frage: was tun? WooCommerce nie wieder updaten? Mein Problem war/ist eine fehlerhafte MwSt-Berechnung, daher kam ich überhaupt auf die Idee Updates zu fahren, obwohl ich mit dem Kunden keinen Service-Vertrag habe. Und SCHWUPPS war der Shop Offline. Nun stehe ich mehr oder weniger am Anfang des Problems: Updates machen oder nicht und dann weiter auf Fehlersuche? Kann das so ja nicht lassen. Beste Grüße aus Berlin, Tim

    Hey Christina, bei mir steht das Ganze in Zeile 296. Der Fix hat aber geklappt, zumindest komme ich jetzt wieder auf die Seite 😉 Nun stellt sich die Frage: was tun? WooCommerce nie wieder updaten? 😉 Mein Problem war eine fehlerhafte MwSt-Berechnung, daher kam ich überhaupt auf die Idee Updates zu fahren. Und SCHWUPPS war der Shop Offline. Nun stehe ich mehr oder weniger am Anfang des Problems: Updates machen oder nicht und dann weiter auf Fehlersuche? Kann das so ja nicht lassen. Beste Grüße aus Berlin, Tim

    ***EDIT*** Habe alle Updates gemacht, nun stimmt die berechnung der MwSt und alles läuft. Denke es könnte das Germanized Plugin gewesen sein. Danke.

    • This reply was modified 2 years, 8 months ago by berlinizer75. Reason: Problem solved
    Plugin Support Andreas W.

    (@aweissinpsyde)

    Problem wurde mit der neuen PayPal Plus Version behoben

    Hallo,

    ich habe ebenfalls Probleme mit der Einbindung von PayPal Plus. Das System zeigt mir folgende Fehlermeldung an : PayPal Plus requires PHP version 5.6 or higher. You are running version 5.4.45

    Ich benutze die Version PHP 7.0

    Kann mir jemand weiterhelfen, was ich machen muss?

    LG

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Fehler bei Installation’ is closed to new replies.