Support » Plugin: Statify » Fehler bei der Aktivierung des Plugins, Tabelle wp_statify wird nicht angelegt

  • Resolved vilmoskoerte

    (@vilmoskoerte)


    Fehler bei der Aktivierung des Plugins, Tabelle wp_statify kann nicht angelegt werden:

    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: "NOTICE: PHP message: WordPress-Datenbank-Fehler Index column size too large. The maximum column size is 767 bytes. für Abfrage CREATE TABLEwp_statify` (”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” id bigint(20) unsigned NOT NULL auto_increment,”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” created date NOT NULL default ‘0000-00-00’,”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” referrer varchar(255) NOT NULL default ”,”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” target varchar(255) NOT NULL default ”,”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” PRIMARY KEY (id),”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” KEY referrer (referrer),”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” KEY target (target),”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” KEY created (created)”
    [09-Jun-2018 22:43:27] WARNING: [pool www] child 20243 said into stderr: ” ) von activate_plugin, do_action(‘activate_statify/statify.php’), WP_Hook->do_action, WP_Hook->apply_filters, Statify_Install::init, Statify_Install::_apply, Statify_Table::create, dbDelta”`

    Und das sagt Health:

    
    				### WordPress ###
    
    Version: 4.9.6
    Sprache: de_DE
    Permalink-Struktur: /%year%/%monthnum%/%day%/%postname%/
    Verwendet diese Website HTTPS?: Ja
    Kann sich jeder auf dieser Website registrieren?: Nein
    Standard-Kommentarstatus: open
    Ist dies ein Netzwerk?: Nein
    Benutzeranzahl: 2
    Kommunikation mit WordPress.org: WordPress.org ist erreichbar
    Erzeuge Loopback Requests: Der Loopback Request für deine Website wurde erfolgreich abgeschlossen.
    
    ### Größe der Installation ###
    
    Uploads-Verzeichnis: 2,39 GB
    Theme-Verzeichnis: 4,73 MB
    Plugin-Verzeichnis: 7,61 MB
    Datenbank-Größe: 49,55 MB
    Gesamtes WordPress-Verzeichnis: 2,43 GB
    Gesamtgröße der Installation: 2,48 GB
    
    ### Aktives Theme ###
    
    Name: Twenty Seventeen
    Version: 1.6
    Autor: dem WordPress-Team
    Website des Autors: https://de.wordpress.org/
    Parent Theme: Kein Child Theme
    Unterstützte Theme-Funktionalität: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, starter-content, custom-header, widgets
    
    ### Andere Themes (3) ###
    
    Astra (astra): Version 1.3.3 von Brainstorm Force
    FontFolio Theme (fontfolio): Version 2.0 von Marios Lublinski
    Twenty Sixteen (twentysixteen): Version 1.5 von dem WordPress-Team
    
    ### Must Use Plugins (1) ###
    
    Health Check Disable Plugins: Version 1.3
    
    ### Aktive Plugins (12) ###
    
    Antispam Bee: Version 2.8.1 von pluginkollektiv
    Avatar Privacy: Version 1.0.7 von Peter Putzer, Johannes Freudendahl
    Broken Link Checker: Version 1.11.5 von Janis Elsts, Vladimir Prelovac
    Contact Form 7: Version 5.0.2 von Takayuki Miyoshi
    Cookie Consent: Version 2.3.10 von Catapult_Themes
    Display Posts Shortcode: Version 2.9.0 von Bill Erickson
    Embed videos and respect privacy: Version 2.0 von Michael Zangl
    Health Check: Version 1.1.0 von The WordPress.org community
    Import External Images: Version 1.4 von Marty Thornley
    Remove  Open Sans font from WP core: Version 1.2.2 von suifengtec
    Statify: Version 1.6.3 von pluginkollektiv
    Tiled Galleries Carousel Without Jetpack: Version 3.0 von Raja CRN
    
    ### Inaktive Plugins (1) ###
    
    WordPress Importer: Version 0.6.4 von wordpressdotorg
    
    ### Medienhandling ###
    
    Aktiver Editor: WP_Image_Editor_Imagick
    Imagick Modul Version: 1689
    ImageMagick-Version: ImageMagick 6.9.9-50 Q16 x86_64 2018-06-04 https://www.imagemagick.org
    Imagick-Resource-Limits: 
    	area: 31 GB
    	disk: -1
    	file: 768
    	map: 31 GB
    	memory: 15 GB
    	thread: 20
    GD-Version: 2.2.5
    Ghostscript-Version: 9.07
    
    ### Server ###
    
    Server-Architektur: Linux 3.10.0-693.21.1.el7.x86_64 x86_64
    PHP-Version: 7.1.18 (Unterstützt 64bit-Werte)
    PHP SAPI: fpm-fcgi
    PHP max input variables: 1500
    PHP time limit: 600
    PHP memory limit: 256M
    Max input time: 600
    Maximale Dateigröße Upload: 512M
    PHP post max size: 512M
    cURL-Version: 7.29.0 NSS/3.34
    SUHOSIN installiert: Nein
    Ist die Imagick-Library verfügbar: Ja
    htaccess rules: Deine htaccess-Datei enthält nur WordPress-Funktionen
    
    ### Datenbank ###
    
    Erweiterung: mysqli
    Server-Version: 5.5.5-10.1.33-MariaDB
    Client-Version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    Datenbankpräfix: wp_
    
    ### WordPress-Konstanten ###
    
    ABSPATH: /var/www/virtual/stahl/html/vilmoskörte.de/
    WP_HOME: Nicht definiert
    WP_SITEURL: Nicht definiert
    WP_DEBUG: Deaktiviert
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Aktiviert
    WP_DEBUG_LOG: Deaktiviert
    SCRIPT_DEBUG: Deaktiviert
    WP_CACHE: Deaktiviert
    CONCATENATE_SCRIPTS: Nicht definiert
    COMPRESS_SCRIPTS: Nicht definiert
    COMPRESS_CSS: Nicht definiert
    WP_LOCAL_DEV: Nicht definiert
    
    ### Dateisystem-Rechte ###
    
    Das Haupt-WordPress-Verzeichnis: Schreibbar
    Das Verzeichnis wp-content: Schreibbar
    Das Uploads-Verzeichnis: Schreibbar
    Das Plugin-Verzeichnis: Schreibbar
    Das Theme-Verzeichnis: Schreibbar
    Das Must-Use-Plugin-Verzeichnis : Schreibbar
    
    

    Was kann ich tun? WordPress und PHP sind eine BlackBox für mich. Kann ich die max columns size irgendwie ändern?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Stefan Kalscheuer

    (@stklcode)

    Hallo vilmoskoerte,

    dein System verwendet scheinbar eine MySQL InnoDB ohne die large_prefix_extension. Damit können keine Indizes auf referrer und target angelegt werden, da diese mit 255 Zeichen (je 4 Byte) zu groß sind.

    Davon ausgehend, dass es nicht dein eigener DB Server ist, wirst du auf die Einstlelung wahrscheinlich keinen Einfluss haben.

    Workaround: Entferne die Keys.
    * Gehe dazu auf Plugins -> Editor
    * Oben rechts Statify wählen
    * Rechts die Datei inc/class-statify-table.php wählen
    * Zeilen 69 und 70 löschen:
    KEYreferrer(referrer)
    KEY target (target)

    Nachteile: Leichte Performance-Einbußen im Admin-Interface, wenn du nicht gerade mit Millionen Besuchern oder jahrelanger Statistik arbeitest, vermutlich kaum spürbar.

    Gruß,
    Stefan

    Hallöchen,

    ich schließe mich hier mal an. Host ist uberspace.
    Vielleicht ließe sich für das nächste Update ja eine Überprüfung mit einbauen?

    Danke Stefan für Analyse und Workaround. Problem “gelöst”.

    Lg,
    Tobias

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fehler bei der Aktivierung des Plugins, Tabelle wp_statify wird nicht angelegt’ is closed to new replies.