Support » Plugin: SIS Handball » Fehler bei Aktivierung

  • Resolved mars93

    (@mars93)


    Hallo ich habe bei der aktuellen Version folgendes Problem:

    Parse error: syntax error, unexpected ‘[‘ in /var/www/web5/web/wp-content/plugins/sis-handball/public/class-sis-handball-public.php on line 309

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Felix W.

    (@welly2103)

    Hi @mars93

    welche PHP Version nutzt du?

    Grüße

    PHP 5.2.6.1 nutze ich. Ich habe auf die Version auch leider keinen Einfluss.

    Plugin Author Felix W.

    (@welly2103)

    Hi @mars93

    ohne ein Update auf php 5.6 oder im Idealfall sogar PHP 7 funktioniert das Plugin leider nicht. WordPress unterstützt diese PHP Versionen zwar noch, rät aber auch dringend davon ab unterhalb von PHP 5.6 zu arbeiten.

    Siehe: https://wordpress.org/about/requirements/

    Das tut mir leid.

    Ich hatte das gleiche Problem. Da ich allerdings die php-Version explizit nur für die WP Installation ändern wollte, habe ich in der .htaccess Datei im WP-Installationsverzeichnis folgende Zeilen ganz oben eingefügt.

    
    # verwende php 5.6 für WordPress
    AddType application/x-httpd-php56 .php .php4 .php3 .php5
    

    Damit läuft WP mit der PHP Version 5.6

    Plugin Author Felix W.

    (@welly2103)

    @mars93

    der Vorschlag von @ssv ist natürlich eine Option, sofern die PHP Version auf dem Server installiert ist. Hilft dir das weiter?

    Grüße

    @ssv Danke für den Vorschlag.

    Leider funktioniert dieser Workaround nicht, da die Version wohl nicht installiert ist. Aber ich weiß nun wo das Problem liegt und werde versuchen das Problem der PHP Version zu lösen.

    Danke für die Hilfe.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fehler bei Aktivierung’ is closed to new replies.