Support » Plugins » FeedWordPress plugin imports only date and title, not content

  • So, we’re a few friends who wish to syndicate our individual blogs on a WordPress blog (2.0.5) we run together. I’ve tried using Rad Geek’s FeedWordpress plugin, which seems to do exactly what we need (syndicating posts as regular entries in the WordPress blog).

    It works fine up to the point of actually aggregating the feed (testing with only one feed so far). When I run update-feeds.php, the feed gets imported, sort of, but only post_date, post_title and guid — post content, for example, is empty in the database.

    And yes, I’ve checked the feed (an Atom feed from Squarespace), it has the full content. So what’s not working?

    Alternatively, is there some other plugin that does the same trick? If it works without cron, all the better.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I can’t remember the URL, but Elliot has a plugin called wp-autoblog. Just do a search in the forum or google it. This plugin works well with wp-cron which allows cron updates without having to use cron on server. kinda a nice option.


    Thanks for the tip, now I’ve tried Elliot’s WP-Autoblog plugin. Looks perfect, but it doesn’t work at all for me.

    I add a few feeds, click “Run script now”, the browser reloads and… nothing happens. No new posts are imported to wp_posts.

    And yes, the feeds are okay, I’ve checked that they are working and valid.

    Hm, am I missing something here? Some other requirements, maybe?

    Actually, on my second try it did work, but it only syndicated one of my two test feeds. Autoblog wouldn’t fetch this Squarespace Atom 1.0 feed, even though it validates:

    Any ideas why it fails?

    You might want to check the web server error log. I was having a similiar issue and it turned out to be a problem with the parsing of the dates. If you do a search here for “gmmktime” you will find my fix.

    It turns out that I though nothing was happening for me, but in reality all of the posts were being added to my DB, but with ancient 1970 dates, so they weren’t showing up on my site’s front page.

    i’m using feedwordpress as well (see here: but the imported blogger posts are blank. other types of blogs are okay except for blogger. i checked my error logs in cpanel but it really says nothing. can anybody help? 🙂

    I have replied for the solution of this problem
    at this thread, please check here

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘FeedWordPress plugin imports only date and title, not content’ is closed to new replies.