Support » Plugins » Feedwordpress Fatal Error with WP3

  • I searched Google and found other sites with errors but no solution. I upgraded Feedwordpress plugin as it said it had a problem with an outdated rss.php file. I upgraded to WP 3.0 and all went well. FWP wasn’t working and I got this error:

    Fatal error: Cannot use object of type WP_Error as array in /mysite/www/wp-content/plugins/feedwordpress/compatability.php on line 31

    Can’t figure out the problem. Supposedly it is 3.0 compatible.

Viewing 3 replies - 1 through 3 (of 3 total)
  • There’s a fatal error in WP 2.9.2, as well.

    Have you tried deactivating other plugins to see if there is a conflict? I’m running WP 3.0 and FeedWordPress 2010.0623, and it works for me.

    Hi, hope I am not too late with this answer. I am certainly not an expert in any of this, but have taken enough advantage of these forums to feel the need to give back. I had exactly the same problem, and tried many different things, reinstalling the plugin, wordpress, the theme (THESIS 1.7), and still kept getting this error. I had a problem with thesis 1.7 after the upgrade with the custom file editor and the solution was to go that line, and add // to the front of it, to “escape” it, and it worked like a champ. That is a separate matter, but if you have the same problem, it works. Anyway, taking my cue from that, I read through the compatability(mispelled?, oh well) .php file on line 31. From what I could gather it had to do with backwards compatibility with earlier versions of WP. So, I experimentally added // to the front of line 31, thereby “escaping” it out, and voila! Everything works like it is supposed to.
    I tried deactivating plug ins one by one, reinstalling WP, everything, and this simple little “cheat” worked. If anyone knows why, or how, or if it is bad or any of those negative things, let me know, but it is rocking like it is supposed to now! Yeah. Let me know if that helps!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Feedwordpress Fatal Error with WP3’ is closed to new replies.