Support » Plugin: FeedWordPress » FeedWordPress and WYSIWYG

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author C. Johnson


    Hi Morgan,

    Thanks for writing about this. This behavior is deliberate.

    The reason why FeedWordPress does this is because of an unfortunate feature of the Visual Editor — even though it is capable of understanding posts in full, ready-to-display HTML, it actually strips out a great deal of HTML when you save posts in it — on the assumption that paragraph breaks will be restored by WordPress’s built-in formatting filters. However, since FeedWordPress stores syndicated posts in full, ready-to-display HTML, and deliberately bypasses WordPress’s formatting filters for syndicated posts, this causes an issue where any syndicated posts that are edited in the Visual Editor will usually show up with all their line-breaks and paragraph breaks seemingly stripped out. This was frequently reported as a bug by FWP users in earlier releases, so in order to avoid the possible bad interaction, I simply disabled the Visual Editor for syndicated posts (since it deals so poorly with them in general).

    If it’s important to you to get the Visual Editor back, I think I can actually work out a quick compromise solution, which will enable the Visual Editor for syndicated posts if and only if you have FeedWordPress set up to expose syndicated posts to formatting filters, rather than bypassing formatting filters as it normally does. If you have that setting turned on, then the effects that Visual Editor has on syndicated posts’ HTML should not cause the harmful results that were seen when it is turned off. Does that sound like something that would work better for you? If so, let me know, and I’d be happy to drop a note onto this thread when the compromise fix is ready.


    Thank you, Radgeek, for your thorough explanation! It would be wonderful if you could apply this compromise fix. I really appreciate it!

    Plugin Author C. Johnson


    Hey Morgan,

    No problem. It didn’t get into the 2012.1212 release because I needed to move quickly on a couple of other issues, but it will be in the next iterative release, which should hopefully happen over the weekend or the beginning of next week.

    In the meantime, while you are waiting on that fix, here is a quick fix that should forcibly override what FWP is trying to do, if you are able to edit the files in your WordPress Theme. Open up your functions.php file in an editor, and add the following code near the top, somewhere underneath the opening <?php prefix but before much of anything else happens in the script:

    1001, // After FWP
    function user_can_too_richedit_feedwordpress ($rich_edit) {
    return true; // Override FWP's override

    If you try this out, let me know whether it works for you. If not, I’ll do a few tests to try to troubleshoot. If so, then great; you should only need to leave it in functions.php for a few days until the new FWP release supplies a better fix.

    Hi Charles,

    First of all, I am a long time user, love FWP, could not live without it:-)

    But I must say I am now quite shocked to see what I thought was a bug is actually a decision you’ve made .. perhaps my use case is very different from the majority (I don’t auto-publish, manually edit everything), but I think it is a dramatic choice, and a bad one. I can’t edit posts in a text-only environment.

    Of course before reading this thread, I ahad no clue what the reason was, all I saw that visual editor disappeared after the WP 3.5 upgrade. It took a while to figure out it was caused by FWP. So now my solution is to downgrade back to the previous FWP release, which allows use of WP visual editor.

    Now, to the core of the story: I’ve always (for years) had the “expose to formatting filters” setting on, can’t remember what the reason was, just that I had better results that way. Even then, some posts show up with line breaks stripped out – but that’s just 2-3 of my 50+ source feeds. Still, I can deal with those better than losing Visual Editor.

    I’ll try your fix on a test site, but until then I’ll leave my productive FWP at the previous release.

    Thanks a lot!

    I can see why you’d decide to remove the WYSIWYG editor. I can also see why having that as a plugin option – default off, perhaps – would be the perfect solution. I’m with ZollEdros and my use case needs the editor on – even if that means some clean up from time to time. Technically speaking, we are cleaning up all feeds anyhow and are just using the feeds to save the effort of copying content into the site from sister sites.

    I just added your functions filter suggestion and it worked perfectly. Thanks for that.

    This plugin is great and very helpful.

    Great to see this is being addressed, and thanks for the workaround in the interim. I use your plugin as the primary engine behind several planet sites, all without auto-publishing, mostly because all too often I have to edit post formating before the content works well with my theme/design. Having this as a plugin option would be a great way to split the middle and let site admins choose the behavior that works best for them.

    Did I mention this is the best wordpress plugin ever? Keep up the great work and excellent support!

    Hi Radgeek, A couple of us were discussing this over here:

    I have my installation of FWP exposed to filters. Sometimes i want to quickly edit a syndicated post to add another link or a video, etc. So the visual editor is best for me. Another member said temporary disabling FWP will bring the visual tab back but i have not tried it yet, but it’s an easy toggle if it works.

    Will send a small token of my appreciation your way shortly.

    I also rely on the wordpress editing window to fine-tune syndicated posts. Without the wordpress editor the job would be almost impossible.

    FeedWordPress is an amazing plugin and one I rely upon heavily. Hope you can re-install the editing window as a standard on this outstanding plugin.

    Plugin Author C. Johnson


    Hey y’all,

    Thanks for the report backs on this, and for the kind words. I am sorry for any unpleasant surprises that the original decision may have caused. I just wanted to let you know that I’ve implemented the solution I mentioned above for the Visual Editor tab: it will now appear, but if and only if the setting under Posts & Links > Formatting Filters is set to “Expose syndicated posts to formatting filters.” When this setting is set to “Protect,” using the Visual Editor to edit posts would result in mangled formatting on posts (mainly, edited posts will look like they’ve had all their paragraphs-breaks and line-breaks stripped out). So in that case the Visual Editor will be disabled. But if this setting is set to “Expose,” using the Visual Editor won’t have the same bad effects on formatting. So if it is set to “Expose,” then the Visual Editor tab will appear when editing syndicated posts.

    The fix is available currently on Github, and will be rolled into the next incremental release of FeedWordPress, which I plan to release tomorrow (Monday 12/17) after I’ve had a chance to run through other outstanding issue reports.

    Kudos, and many thanks, radgeek!

    First of all, thank you for the great work!!!

    I also do need the WYSIWYG editor for syndicated posts pretty badly. I am making a daily newspaper out of the best (german speaking) blogs. So i have to read the articles before publishing and of course edit them, change pictures etc.
    That is why i was shocked too, when trying to update my site today 🙂
    I always had the articles exposed to the filters and never really had a problem with it!
    Please, please give us that feature back 🙂

    many thanks,

    Plugin Author C. Johnson


    Hey all,

    So, I just wanted to let you know that the fix for this issue that I described above (Visual Editor on when posts are exposed to formatting filters, off when they bypass formatting filters) should be available in 2012.1218, released today (announcement here: , code available through WordPress plugin repository here: or at Github here: ). Let me know if this works for you; for the time being, I’ll mark this issue as resolved, if that’s alright.


    Appears to be working, thanks for the fix!

    Thank you, Radgeek! I’m really impressed by the fast fix!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘FeedWordPress and WYSIWYG’ is closed to new replies.