/feeds is working, but wp-rss2.php is not (22 posts)

  1. gloddy
    Posted 10 years ago #

    After upgrading to wordpress 2, /feeds works, but wp-rss2.php just drops the following:
    <!-- generator="wordpress/2.0" -->
    <rss version="2.0">
    <title>Obvious Diversion</title>
    <pubDate>Wed, 04 Jan 2006 20:42:52 +0000</pubDate>

    Any ideas what's going on? I checked the

  2. thornomad
    Posted 10 years ago #


    I just upgraded and I have the same problem. However, I think it might be my fault: I left my one and only plugin activated when I did the upgrade ... the "betterfeed" plugin. I don't know if that is what caused the problem, but I seem to have the exact same symptoms. The /feed/ permalinks work fine, but not the wp-rss2.php calls.

    Any idea how to fix that anyone? I have my iTunes podcast pointing to the wp-rss2.php feed ... yikes!



  3. gloddy
    Posted 10 years ago #

    ok, i haven't a clue as to how to fix this. Ideas anyone?

  4. gloddy
    Posted 10 years ago #

    I've removed all my plugins. Still didn't work. Then made sure I had the latest and greatest of my plugins and that they were verified to work with wordpress 2.0. Still no dice.

    I'm stuck as to what to do next.

  5. gloddy
    Posted 10 years ago #

    Russell Beatie is having the exact same problem:

  6. gloddy
    Posted 10 years ago #

    Temporary fix:
    1. open up your htaccess file
    2. right after "RewriteEngine On" paste the following on a new line

    RewriteRule ^wp-rss2.php$ http://yoursite.com/feed/rss2/ [L]
    RewriteRule ^wp-rss.php$ http://yoursite.com/feed/rss/ [L]
    RewriteRule ^wp-atom.php$ http://yoursite.com/feed/atom/ [L]

    This is temporary and may not work for all rss readers, but it's the best i can do until there is a fix.

  7. mactoph
    Posted 10 years ago #

    Just a note that I am dealing with the same problem- any insight that anyone has would be greatly appreciated...

    all show only the feed header information (correctly) and none of the individual post information since I have upgraded to 2.0. Before that, the feeds worked fine... I'm still figuring my way around WP and haven't been able to figure out what is common to all of these that isn't working- any ideas?

    I am using a theme that I used in 1.5, is there something in the new themes that could be causing it? Any thoughts, ideas or other posts are greatly appreciated-

    Thanks for the temporary fix gloddy.

  8. hulksjedi
    Posted 10 years ago #

    Exactly, I'm having the SAME problem! can anyone help us!?

  9. japanwindow
    Posted 10 years ago #

    I just started my blog using WP 2.0, so no history here. When I subscribe to RSS 2.0 with Firefox it comes up empty. I checked at Feed Validator and got this result:

    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    Any help would be appreciated.

  10. mactoph
    Posted 10 years ago #

    I found out what the issue was for me, I was using the %category% structure tag in my permalinks, and as noted on this page:

    "%category% does not work correctly with some implementations of mod_rewrite in Apache versions prior to 2."

    For some reason this wasn't an issue for me with 1.5, but is is with 2.0, so I just removed %category% from my permalink structure and it is working fine now.

    Hopefully that is helpful to someone out there-

  11. thornomad
    Posted 10 years ago #

    That is helpful -- but it is unfortunate! I like having the %category% info in my link. I am just using the /feed/ for now.

  12. carsten
    Posted 10 years ago #

    I had the same problem, but the RewriteRule solution proposed by gloddy didn't work for me, so I decided to simply redirect the whole thing:

    Redirect /wp-rss2.php http://www.yoursite.com/feed/rss2/
    Redirect /wp-rss.php http://www.yoursite.com/feed/rss/
    Redirect /wp-atom.php http://www.yoursite.com/feed/atom/

    I hope this helps. I'm not quite sure wether some RSS readers have a problem with being redirected, but it seems to work fine with Bloglines and Thunderbird.

  13. jdrumgoole
    Posted 10 years ago #

    This stopped working for me as well. I tracked it down to using the /%postname%/ permalink syntax. When I switched back to the default stucture the wp-rss2.php feed started working again.

    Lucky thing I look at my own feed in bloglines otherwise I would have been silently ignored by the world, the horror :-) :-)

  14. IsraelBarros
    Posted 10 years ago #

    I solve this problem with this way.
    Try to do this:

  15. DaveW
    Posted 10 years ago #

    I've just had this pointed out to me on our site too. I've been through several RSS readers (FeedReader, SharpReader, BlogBridge, Amphetadesk, and RSSOwl) and they all find the feed but with no items in it as gloddy reported at the top.
    The feed on http://URL/?feed=rss works only if you type it into a browser (both IE and Firefox work) in that the items are shown, but in case it helps with the diagnostics, the FF RSS reader Sage is the only reader/aggregator I've found that finds the items. I don't know what it's doing differently, but it might provide a clue.
    PS. I'm not using permalinks (I don't think) so wouldn't be affected by those.

  16. DaveW
    Posted 10 years ago #

    Just an afterthought (but it might be worth checking) as the RSS container seems to be recognised ok by most readers, but the contained items aren't, are they being written properly (RSS-compliant)?

  17. DaveW
    Posted 10 years ago #

    New news. With no expectations, I updated to 2.0.2 and my Sage (Firefox) reader stopped seeing the RSS2 feed. However, a friend of mine tells me that his GreatNews reader has been able to read the feed since before I did the upgrade. Are we looking at a content-specific bug here? Are some of the reserved XML/RSS characters not being properly trapped? (It doesn't explain why I can't see anything other than the header, but that might be my reader too...)

  18. DaveW
    Posted 10 years ago #

    Wait! My RSS reader (Sage) has started working again... And it seems to be because I added '?xxx' to the end of wp-rss2.php in the feed properties. I think it's a (bizarre) cacheing problem. There's no other explanation for it. (Is there?)

  19. DaveW
    Posted 10 years ago #

    Well, I think I've found out what it is, and (doh) it's fairly obvious. I've got the Category Access plug-in installed and, of course, the feed can't tell which categories it's allowed to serve unless you're logged in. With CA turned off, the feed works fine. Turn it back on and it chokes. (There is also confusion caused by cacheing somewhere up the chain, but I don't think that's anything to do with the root cause.)
    Problem understood, if not solved.

  20. iacas
    Posted 9 years ago #

    FWIW, this appears to have been documented and fixed for version 2.1. I guess us "lowly" 2.0 users will have to wait for the fix.

    Here's the brief discussion in Trac: http://trac.wordpress.org/ticket/3214.

  21. I've backported the patch for 2.0.8.

    It's available on trac for you to test out if you wish.

  22. puzder
    Posted 9 years ago #


    with regards to my page http://www.setmusicfree.info

    can you direct me to come help - I originally set the permalinks up %category% as the first variable. RSS was nto working. I went back to default and RSS still does nto work - the link just goes to a blank page. I am a *novice* at this. I have similar code which works successfully for a client at lowfeefofummortgage.com.

    I am lost.


Topic Closed

This topic has been closed to new replies.

About this Topic