Support » Fixing WordPress » /feeds is working, but wp-rss2.php is not

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi,

    I just upgraded and I have the same problem. However, I think it might be my fault: I left my one and only plugin activated when I did the upgrade … the “betterfeed” plugin. I don’t know if that is what caused the problem, but I seem to have the exact same symptoms. The /feed/ permalinks work fine, but not the wp-rss2.php calls.

    Any idea how to fix that anyone? I have my iTunes podcast pointing to the wp-rss2.php feed … yikes!



    Thread Starter gloddy


    ok, i haven’t a clue as to how to fix this. Ideas anyone?

    Thread Starter gloddy


    I’ve removed all my plugins. Still didn’t work. Then made sure I had the latest and greatest of my plugins and that they were verified to work with wordpress 2.0. Still no dice.

    I’m stuck as to what to do next.

    Thread Starter gloddy


    Russell Beatie is having the exact same problem:

    Thread Starter gloddy


    Temporary fix:
    1. open up your htaccess file
    2. right after “RewriteEngine On” paste the following on a new line

    RewriteRule ^wp-rss2.php$ [L]
    RewriteRule ^wp-rss.php$ [L]
    RewriteRule ^wp-atom.php$ [L]

    This is temporary and may not work for all rss readers, but it’s the best i can do until there is a fix.

    Just a note that I am dealing with the same problem- any insight that anyone has would be greatly appreciated…

    all show only the feed header information (correctly) and none of the individual post information since I have upgraded to 2.0. Before that, the feeds worked fine… I’m still figuring my way around WP and haven’t been able to figure out what is common to all of these that isn’t working- any ideas?

    I am using a theme that I used in 1.5, is there something in the new themes that could be causing it? Any thoughts, ideas or other posts are greatly appreciated-

    Thanks for the temporary fix gloddy.

    Exactly, I’m having the SAME problem! can anyone help us!?

    I just started my blog using WP 2.0, so no history here. When I subscribe to RSS 2.0 with Firefox it comes up empty. I checked at Feed Validator and got this result:

    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    Any help would be appreciated.

    I found out what the issue was for me, I was using the %category% structure tag in my permalinks, and as noted on this page:

    “%category% does not work correctly with some implementations of mod_rewrite in Apache versions prior to 2.”

    For some reason this wasn’t an issue for me with 1.5, but is is with 2.0, so I just removed %category% from my permalink structure and it is working fine now.

    Hopefully that is helpful to someone out there-

    That is helpful — but it is unfortunate! I like having the %category% info in my link. I am just using the /feed/ for now.

    I had the same problem, but the RewriteRule solution proposed by gloddy didn’t work for me, so I decided to simply redirect the whole thing:

    Redirect /wp-rss2.php
    Redirect /wp-rss.php
    Redirect /wp-atom.php

    I hope this helps. I’m not quite sure wether some RSS readers have a problem with being redirected, but it seems to work fine with Bloglines and Thunderbird.

    This stopped working for me as well. I tracked it down to using the /%postname%/ permalink syntax. When I switched back to the default stucture the wp-rss2.php feed started working again.

    Lucky thing I look at my own feed in bloglines otherwise I would have been silently ignored by the world, the horror 🙂 🙂

    I solve this problem with this way.
    Try to do this:

    I’ve just had this pointed out to me on our site too. I’ve been through several RSS readers (FeedReader, SharpReader, BlogBridge, Amphetadesk, and RSSOwl) and they all find the feed but with no items in it as gloddy reported at the top.
    The feed on http://URL/?feed=rss works only if you type it into a browser (both IE and Firefox work) in that the items are shown, but in case it helps with the diagnostics, the FF RSS reader Sage is the only reader/aggregator I’ve found that finds the items. I don’t know what it’s doing differently, but it might provide a clue.
    PS. I’m not using permalinks (I don’t think) so wouldn’t be affected by those.

    Just an afterthought (but it might be worth checking) as the RSS container seems to be recognised ok by most readers, but the contained items aren’t, are they being written properly (RSS-compliant)?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘/feeds is working, but wp-rss2.php is not’ is closed to new replies.