Support » How-To and Troubleshooting » Feeds give only summary when I want full-text

Feeds give only summary when I want full-text

  • My blog at jasonswadley.com is only giving summaries in the RSS and atom feeds, rather than the full text. I have the option for “Full Text” selected in the Reading settings box. The feedburner plugin is deactivated.

    Thanks for your help!

    Google Analytics for WordPress
    Google XML Sitemaps

Viewing 15 replies - 1 through 15 (of 19 total)
  • I had trouble with this recently too, it more than likely has something to do with the feed address your using.
    Have you looked at http://codex.wordpress.org/WordPress_Feeds

    Hi, thanks for the fast reply.

    I checked all the feed links… they’re all giving me the same summary view.



    Sorry then, I’m a bit lost too. Mine happened when I switched from blogger.

    Anyone else have any ideas?



    Forum Moderator

    Your feed does include the full post. Whether the full post is displayed in your feed reader is another matter entirely and completely beyond the control of WordPress.

    Actually esmi, the feed doesn’t include the full post. I’ve checked in numerous readers, and the result is always the same.

    The problem is with the feed itself, not the readers.

    All of these posts are Aside formats, by the way, though I don’t think that should change anything.



    Forum Moderator

    I actually checked the raw rss file. The posts are there in full. Have a look at the source of the feed file yourself.

    Thanks esmi, that’s useful!

    So why is every feed reader I’ve tried drawing on what’s in the <description> tag rather than the actual content? Here’s the output of one post:

    		<title>Harvey Mansfield on the humanities</title>
    		<pubDate>Wed, 18 May 2011 02:51:20 +0000</pubDate>
    		<dc:creator>jason swadley</dc:creator>
    		<guid isPermaLink="false">http://www.jasonswadley.com/?p=644</guid>
    		<description><![CDATA[Harvey Mansfield on the humanities: “It is the job of the humanities to make non-science into something positive that could be called human in the best sense.”]]></description>
    			<content:encoded><![CDATA[<p><a href="http://www.city-journal.org/2011/eon0517hm.html">Harvey Mansfield on the humanities</a>: “It is the job of the humanities to make non-science into something positive that could be called human in the best sense.”</p>


    Forum Moderator

    I can’t account for what the feed readers choose to display. Nor can WordPress control that. Sorry 🙁

    Thanks esmi, but this is pretty clearly a problem with wordpress – there was one point when I checked the feeds and it was working, and now it isn’t.

    The readers can only display what wordpress tells them to display, and for whatever reason there’s an issue between the two.

    Any other ideas anyone?

    Suggestions? Thanks in advance!

    Bump for help. Hunting around the forums, I know I’m not the only one with similar issues. Thanks!

    Not to sound desperate… but I’m desperate. Would reinstalling help? That seems messy.

    The full feed was showing, but now it’s not, and I can’t for the life of me identify the cause of the change.

    I’m having the same problem since I installed the last WordPress update a few days ago. I was publishing a full feed and it changed to summaries. My Feedburner account is set to full feed and so it the WordPress setting. Any help?

    I’ve still had the same issue with all the updates… I’ve tried everything I know.

    Maybe it’s a botched installation? I haven’t had the heart to delete and reinstall.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Feeds give only summary when I want full-text’ is closed to new replies.