Support » Fixing WordPress » Feeds and archives not working

  • Resolved pikeMall

    (@pikemall)


    OK folks, I have WordPress installed, but am having some issues. Whenever I click on any category or archive link, I get a 404 error. Also, if I click on an RSS link I get the following:

    Safari can’t open the page “feed://www.techcastweekly.com/feed/atom/”. The error was: “unknown error” (NSURLErrorDomain:-1) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

    Thanks for your help in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • None of your Permalinks are working. See that link for trouble-shooting tips.

    In particular, ensure your host has mod_rewrite and AllowOverride on and enabled.

    (in the meantime, urls like this work for your feeds: http://www.techcastweekly.com/?feed=rss2 )

    Thanks so much! Up and running in less than 5 minutes!

    I think I’m having similar problems, but I’m not entirely sure what to do about it…

    I didn’t have an .htaccess file set up, now I have a blank one, but what do I put in it?

    By wordpress is at http://www.thehobsite.com/blog

    Cheers 🙂

    If you’re still using Default Permalinks, you don’t need a .htaccess file.

    And you are.

    If you wish to change that, when you visit Options -> Permalinks, WP will display what should be in that file if it can’t write directly to it. in that case, copy/paste will save the day, eh?

    If that’s not enough to get you rolling, you may consider starting a new thread with details.

    Cheers!

    Where does one find the .htaccess file?

    I’m using the default permalinks, but my Entries RSS doesn’t seem to work, while my Comments RSS does.

    I have another blog hosted in another directory of the same domain name, and Entries RSS work but not Comments, and yet another one whereby both work.

    Anyway to make them all work?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Feeds and archives not working’ is closed to new replies.