Support » Plugin: Contact Form 7 » Feedback Message fails to appear

  • Resolved darthambiguous

    (@darthambiguous)


    I’m wondering if the new WP 5 update broke some of the CF7 functions.

    I’m building a new site, and added a contact form (see here: http://2019.wblc.com.au/wp/index.php/market-stall-request/), and before I tested it I added ReCaptcha v3.

    When testing, it would send an email (which seems to be the current problem people are facing), but it wouldn’t display any message – after the spinning wheel at the bottom the screen disappeared, the form would stay on the screen with the text remaining in it.

    I tried missing out filling in required fields, the wheel spun and disappeared, but it didn’t give me an error message, just left the form with text onscreen.

    After reading all the current comments, I removed everything from my site for reCaptcha and tried again. It did the exact same thing. No success or fail message, and the form remained on screen with the text remaining in it. Emails did send, however. But the user would never know that.

    So I turned off non-essential plug-ins (my list of current plug-ins is below), again no change.

    I removed CF7 and reinstalled. Again, no change.

    While obviously I’d love to see this resolved, I believe the issue lies in your plug-ins compatibility with the new WordPress Update, not the reCaptcha update. Just my two cents worth.

    Do you have any better ideas on how this can be fixed?

    Cheers – and thanks for an awesome plug-in!

    WordPress Version 5.0.2–en_AU
    Theme: Avada Version: 5.7.2 By ThemeFusion

    CURRENT PLUG-INS

    Advanced Ads
    Version 1.10.12 | By Thomas Maier

    Advanced Ads – Slider
    Version 1.4.4 | By Thomas Maier

    Advanced Post Manager
    Version 4.4 | By Modern Tribe, Inc.

    Contact Form 7
    Version 5.1.1 | By Takayuki Miyoshi

    Contact Form 7 Shortcode Enabler
    Version 1.1 | By Tobias Zimpel (TZ Media)

    Contact Form 7 Skins
    Version 2.0.1 | By Neil Murray

    Duplicate Page
    Version 3.2 | By mndpsingh287

    Flow-Flow Lite
    Version 3.0.88 | By Looks Awesome

    Fusion Builder
    Version 1.7.2 | By ThemeFusion

    Fusion Core
    Version 3.7.2 | By ThemeFusion

    Google Analytics for WordPress by MonsterInsights
    Version 7.3.3 | By MonsterInsights

    Jetpack by WordPress.com
    Version 6.8.1 | By Automattic

    Mailchimp for WooCommerce
    Version 2.1.11 | By Mailchimp

    OptinMonster API
    Version 1.5.3 | By OptinMonster Team

    Regenerate Thumbnails
    Version 3.0.2 | By Alex Mills (Viper007Bond

    Shortcodes Ultimate
    Version 5.2.0 | By Vladimir Anokhin

    The Events Calendar
    Version 4.7.3 | By Modern Tribe, Inc.

    The Events Calendar Extension: Calendar Widget Areas
    Version 1.0.1 | By Modern Tribe, Inc.

    The Events Calendar Extension: Relabeler
    Version 1.0.1 | By Modern Tribe, Inc.

    The Events Calendar PRO
    Version 4.5.2 | By Modern Tribe, Inc.

    WooCommerce
    Version 3.5.3 | By Automattic

    WooCommerce Checkout Manager
    Version 4.2.3 | By Visser Labs

    WooCommerce Services
    Version 1.18.0 | By Automattic

    Yoast SEO
    Version 9.3 | By Team Yoast

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try switching theme to the default one (Twenty Nineteen or Twenty Seventeen) and deactivating all plugins excluding Contact Form 7, WooCommerce, and Yoast SEO, then try again.

    Well, what do you know. It worked! Why didn’t it do that last time?

    I’ll start re-adding and see who the culprit is.

    It did keep the form on the screen as well as the “thanks for your request” text – is it supposed to do that?

    I turned them all back on individually, emptying the cache after re-adding them, checking the form, they all worked.

    Now tonight it’s stopped working again.

    Ideas?

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Now tonight it’s stopped working again.

    It sounds like a cache-related issue. Are you using a cache plugin?

    All fixed. Thanks for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Feedback Message fails to appear’ is closed to new replies.