Support » Requests and Feedback » Feedback: COMMENTING in 1.5

  • Resolved davejenbarnes


    I had a big stink with learning the new commenting process. I thought my wp-comments-post.php file was broken because some friends of mine experienced NO FIELDS to fill out except the comment area and yet got the message:
    Error: please fill the required fields (name, email).

    Upon deeper research, I learned that there is a complicated process someone must go through to post a comment, which I outlined in my blog:

    Isn’t it truly rediculous that I had to research this and figure it out? I mean, wouldn’t an easier way be to tell people that they have to register and login in order to leave a comment on this blog. I love the spam prevention measures but this is a bit extreme and very misleading. For hours and hours I thought my WordPress was broken. You woudn’t believe how many times I downloaded a new version of it to replace the wp-comments-post.php file!

    Where is a nice middle ground, WordPress? or how do I “tweak” the php to let people know how to comment without having to post a “guide” to tell them what aught to be obvious?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Could you just make sure the ‘must be register and logged in to post’ box is not ticked? Or am I missing something entirely?

    heh yea, I would think taht you’d just need to not force everyone to be registered by making sure that check box isnt’ marked.

    It’s under Options–>General. There’s an area that says “Membership” and the options are:
    Anyone can register
    Users must be registered and logged in to comment

    I think that’s obvious enough.

    nope, that’s not the problem.. If I uncheck that box, NO ONE can leave a comment.

    You would THINK it would be obvious, but I had to go in and check that box in order to be able to let anyone leave a comment at all and it was a friend of mine on another computer that broght the comments problem to my attention in the first place.

    Believe me, the comments are wonky, to quote skillzy.

    Sounds like you had a glitch in your upgrade then, because that is not the normal behavior.

    then I have the glitch in several attempts at upgrading.

    I don’t know what the heck is the problem, but skillzy is having it too:

    OK. Sorry to piggyback here but I can’t seem to figure out how to start a thread. Why is the post a new message button on this forum?? My problem is my comments don’t seem to be working. It just loads and loads…what’s up? My blog is at

    if you uncheck that box, does a comment box even appear?

    I’m having much the same problem — when the “Users must be registered and logged in to comment” is unchecked, you get a comment box and nowhere to put name and email. If you’ve checked “Need name and email” on the commenting options, it rejects the comment; if not, it posts it as anonymous.

    Tried a lot of stuff; read a lot of threads; did a full reinstall. Getting pretty frustrating.

    ahh. i had the exact same problem. mine was because i tampered with it a bit, so i put in a new copy, and put all my tables and other stuff around the existing codes there. in your wordpress admin area, under options -> discussion, the only ones you need are the first 3:
    – Attempt to notify any Weblogs linked to from the article (slows down posting.)
    – Allow link notifications from other Weblogs (pingbacks and trackbacks.)
    – Allow people to post comments on the article

    and under “before a comment appears” make sure none of those are ticked.
    that solved all my problems, and my fields work perfectly now.

    ronco66, you expressed my original problem exactly. I tried the “solution” provided on the comments of one of my blog posts about this and it “worked” but it was not a true solution, just a way around the issue… I’m leaving this thread unresolved because the orginal problem has still not been addressed to my satisfaction, though the “work around” does seem to get things back to the way they were in 1.2.

    okie i shall give u all a simple solution

    login to wordpress as admin
    check that a new user with the name”.” {period or dot whatever u’d like to call it} has been created in the users section. remove this new user and then everything shall work fine

    all who are facing this problem, please do come back to this thread and post if this solution helped you or not, then we can change the status of this problem to “resolved”.



    I have never had a user with the name . or any other unusual user names either. That solution did not work for me previously (I looked for the user name solution before I hacked into the php code and deleted a bunch of stuff) Anyhow… don’t know if this will ever be resolved as I have given up on the whole thing and just settled for the solution Lea provided in the comments:

    Actually, I figured out a way so none of this difficulty has to happen. First of all, yes, comment out or, as I did, delete:

    // If the user is logged in
    if ( $user_ID ) :
    $comment_author = addslashes($user_identity);
    $comment_author_email = addslashes($user_email);
    $comment_author_url = addslashes(str_replace(’http://’, ‘’, $user_url));
    else :
    if ( get_option(’comment_registration’) )
    die( __(’Sorry, you must be logged in to post a comment.’) );

    from your wp-comments-post.php file.

    And then, go to Presentation > Theme Editor > Comments Template

    and then comment out or delete

    <?php else : ?>

    which is located right before
    � size=�22″ tabindex=�1″ />

    AND VOILA!!! It just took me an entire day of fiddling the other day on top of me just experimenting and scouring the WordPress support forums to get this. Whee!



    so… I’ll resolve the thread but that is the “solution” I used… which just gets things back to the way they were in 1.2 instead of fixing the “new” way in 1.5

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Feedback: COMMENTING in 1.5’ is closed to new replies.