WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] feed validation in 1.3 – not at start…

[Resolved] feed validation in 1.3 – not at start…

  • I don’t know when this first occurred, but my rss feed no longer validates. Evidently there is an errant space before <?xml and I cannot figure out where it is coming from. Anyone else have this problem or any idea how to find and fix the problem?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator James Huff

    @macmanx

    Hm, assuming that your feed are at the usual /wordpress/wp-rss2.php, etc, I’m getting “Not a gzipped file (Server response declares Content-Encoding: gzip; misconfigured server?)”. Try disabling or enabling gzip compression. Here’s the validation url: http://www.feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.billhayes.us%2Fwordpress%2Fwp-rss2.php

    Moderator James Huff

    @macmanx

    Have you tried altering either wp-feed or wp-rss2, which ever has the extra space?

    Yep, can’t seem to find where the extra space comes from, hence my question here (just in case someone else has “been there done that”).

    Moderator James Huff

    @macmanx

    Have you tried uploading a new wp-feed or wp-rss2 file? Heh, there has to be a solution, right?

    Yes, I have done all the obvious things. The first thing I did was go to the CVS and re-download the files (I serve off my computer) and then started dl’ing older versions to see where it might have “broken” – no go. It was a lot easier to track down problems when just wp-rss2 was involved.

    Moderator James Huff

    @macmanx

    Interesting, validator still says you have the parsing error, but my browser is displaying the feed just fine now (something it didn’t do a 1/2 hour ago).

    I can tell this is going to be one of those issues that resolves itself some day (hopefully) without my ever knowing what the cause is. I was kinda hoping other 1.3a users were having this problem (sorry ya’ll) but I guess not.
    If anybody comes across anything, please remember to post back here. I’d like to figure this out before I wear a bald spot in my head. 😉

    The very very first character of your index.php is a space.
    Could that be it ?

    Shoot, no. The feed doesn’t work with any of my themes, either so it must be a file in the root directory – but I have re-downloaded them all. It is has to be something obvious otherwise it wouldn’t be this difficult for me to find ;-). But thanks for the thought.

    Moderator Ryan Boren

    @ryan

    In 1.3, all permalinks are directed to the index.php in home/root. index.php includes wp-blog-header.php, which does all of the redirection for themes, feeds, and trackbacks. So, extra stuff in index.php before the inclusion of the blog header can screw up all pages loaded thereafter.

    Yep, thanks, but I am using themes so the index page in the root directory is straight from the CVS. That was one of my first thoughts so it was one of the files I re-downloaded, but still no go. I have sifted through all the files involved in the redirects and I just don’t see anything in them that might be causing the problem 🙁

    Well, like I said – it happened. The feed now is “fixed” so I am left wondering what was wrong and what changed. I did download a couple of files updated in the CVS today, any chance one of those was the culprit??

    It be a gremlin 🙂

    “Sorry, in 1.3 one no longer links directly to the file”
    Is this going to break existing feed URLs or am I misunderstanding?

    Ah, I thought you might have an answer to my question… reread rboren’s post. Those with permalinks will just have the link redirected but as for those who link directly to the file – yes, I suppose so but this is still alpha and may be dealt with before its release.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] feed validation in 1.3 – not at start…’ is closed to new replies.
Skip to toolbar