Support » Plugins » Feed stopped working after upgrading to 2.7

  • Resolved Z_Everson

    (@z_everson)



    Three days ago FeedBurner began showing that I had 0 subscribers. It was around that time that I upgraded to WordPress 2.7.

    Now when I access my feed, I get these error messages. Any idea how I can fix my RSS feed?

    Bang! Kapowww! Krakkk!

    (FeedBurner encountered an error while trying to bring you this feed and is now keeping its head down. Details follow.)
    Feed Address: http://feeds.feedburner.com/ZachEverson

    HTTP Error Code: 500

    Detail: There was a problem retrieving the feed: java.net.SocketTimeoutException: Read timed out

    There has been an error of some kind. Ack!

    FeedBurner could not deliver this feed to you because of the specific problem listed below:
    Feed Address: feed://feeds.feedburner.com/fb/a/feedbackSubmit

    HTTP Error (Code) and Message: (404) Feed not found error: FeedBurner cannot locate this feed URI.

    What can I do about this?
    If you are a potential or current subscriber, contact the publisher to notify them that their feed content is not available. This may be temporary problem that requires their intervention to resolve, or the publisher may have permanently removed the feed from FeedBurner.
    If you are the publisher of this feed, sign into FeedBurner and visit your feed’s “Troubleshootize” tab to view FeedMedic, our automated diagnostic report for your feed. A cause for the problem, and tips for troubleshooting it, may be found there

Viewing 15 replies - 1 through 15 (of 17 total)
  • What is your site URL? There might be a whitespace issue with your RSS feed.

    I’m having a similar problem with my feed (http://cjcs.com/tib):

    Feed Address: http://feeds.feedburner.com/cjcs/TIB

    HTTP Error Code: 500

    Detail: There was a problem retrieving the feed: java.net.SocketTimeoutException: Read timed out

    Frustrating as all get-out.

    My URL is http://www.zacheverson.com. The feed is http://feeds.feedburner.com/ZachEverson, although the original feed is http://zacheverson.com/wp-feed.php.

    Thanks!

    Do you guys have something special in your configuration (like .htaccess) to send the request for the /wp-feed.php file back to Feedburner? I see that there is a plug-in that can also handle it, so I wonder if the plug-in is not 2.7 compatible?

    I think the HTTP 500 error stems from the site going in an endless loop. (Feedburner makes the request to your Web site, gets redirected back to Feedburner, which makes another request to your Web site, etc.) The way it should work is that the User-Agent string for Feedburner should be able to open up the wp-feed.php file without getting redirected, while other users would be redirected to Feedburner.

    Here are the contents of my .htaccess file:

    # Use PHP5 as default
    AddHandler application/x-httpd-php5 .php
    Redirect /feed http://feeds.feedburner.com/ZachEverson/
    Redirect /feed.xml http://feeds.feedburner.com/ZachEverson/
    Redirect /atom http://feeds.feedburner.com/ZachEverson/
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I’d been able to use FeedBurner without having to use the FeedSmith plugin in the past. I’m using Woo Themes’s Type Based theme. In Dashboard > Typbased Options > General settings, there’s a place for me to add my FeedBurner URL, which I did when I set up my website.

    I just installed and activated FeedSmith, however, and added my feed
    (http://feeds.feedburner.com/ZachEverson) to Settings > FeedBurner.
    The problem still exists.

    Also, the FeedBurner comments thread for the site (http://feeds.feedburner.com/ZachEversonComments) works fine though.

    Thanks again for your help!

    I wonder if you moved the FeedBurner redirects underneath the ‘WordPress’ declarations (after # END WordPress) if it would help at all.

    Per the suggestion on another site, I deleted

    Redirect /feed http://feeds.feedburner.com/ZachEverson/
    Redirect /feed.xml http://feeds.feedburner.com/ZachEverson/
    Redirect /atom http://feeds.feedburner.com/ZachEverson/

    That didn’t help either though.

    Turns out deleting it did work. I just needed to into my Feedburner account and point the feed to http://www.zacheverson.com/feed/.

    As for me, I have none of those fun Redirects to delete in the .htaccess for my site:

    AddHandler application/x-httpd-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /tib/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /tib/index.php [L]
    </IfModule>
    
    # END WordPress

    I can’t help but notice that wp-feed.php in 2.6x has:

    if (empty($doing_rss)) {
    	$doing_rss = 1;
    	require(dirname(__FILE__) . '/wp-blog-header.php');
    }
    
    do_feed();

    While the new one in 2.7 is:

    require( './wp-load.php' );
    wp_redirect( get_bloginfo( 'rss2_url' ), 301 );

    It’s similar with wp-rss2.php as well. Clearly something got missed in the recoding. If this problem is to do with looping, I can’t help but wonder if dropping the condition might be a part of the problem.

    Interesting note: if I deactivate the Feedburner plugin, I can get a quick download of my feed ONCE. After that, it just seems to hang like before. I don’t know what exactly is going on, but whatever it is, it’s killin’ me.

    I have been having a similar issue with my blog and rss feed.

    my blog is http://www.72off.net

    anyone have any suggestions for me.

    Peace
    billy

    I finally tracked down the cause of my blow-up. Yet Another Related Posts Plugin 2.1.6, with the “Display related posts in feeds?” option set to ON. Turning the option OFF restored feed functionality. Yay.

    I have the same problem as many others, I cannot ping anything since upgrading to 2.7! It only says my rss-feed is not validated?
    I ran my site through Feed Validator and it said this:
    ———————————————————————–
    Sorry

    This feed does not validate.

    * line 354, column 0: XML parsing error: <unknown>:578:35: unclosed token [help]

    </rss>

    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

    * line 42, column 0: content:encoded should not contain onclick attribute (21 occurrences) [help]

    <content:encoded><![CDATA[<p>What an honor! The house bible for all creat …

    * line 44, column 0: content:encoded should not contain object tag (3 occurrences) [help]

    Check it out: <!– Smart Youtube –><span class=”youtube”><object width=”425 …
    ———————————————————————–
    Anyone got I clue, I havn’t done anything except upgrading to 2.7 – it worked perfectly before that!

    I am having the same problem( Error 500) even when I have not upgraded to wp 2.7

    I have got the same problem since 6 days ago. I am using WP 2.6.

    My site is http://www.go2wellington.com and the feed is http://www.go2wellington.com/feed/

    Any help is much appreciated!

    In my case, I shut off related posts in yarpp and the problem went away…

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Feed stopped working after upgrading to 2.7’ is closed to new replies.