Support » Plugin: WP RSS Aggregator » Feed Sources Won’t Fetch New Items

  • Resolved jpen365

    (@jpen365)


    Hi. I’ve used this plugin successfully for some time on a site that’s basically on auto-pilot. I realized about 2 months ago that it had stopped importing new items. I’ve spent a few hours trying to figure out why and I can’t figure it out. Here are a few details:

    – Hosted on SiteGround.
    – Have tried running the site on PHP 5.6 and 7.
    – Have disabled all other plugins and attempted to fetch items with no luck.

    In a nut shell, here’s what happens. If I navigate to RSS Aggregator > Feed Sources and and click “Fetch Items” under any feed the “Next Update” will reset to 0, but then start counting *up*. For instance, I tried to force all feeds to import about 35 mins ago and right now the Next update value for each feed is “35 mins” and it faithfully ticks up one more minute every 60 seconds and never imports.

    Probably a simple fix, but I’ve been over all the plugin settings to no avail and I find nothing relevant in the PHP error log.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @jpen365,

    Have you tried following the steps outlined on our Feed Items not importing page? If not, please have a go through them and let us know if you still need our further assistance.

    Particularly, please check your cron jobs as is explained here. Since most of the times, this kind of problem is caused by a stuck cron issue.

    This is happening to me too. It has been working for months without a hitch. This morning I noticed last import was 3 weeks ago.

    Also, when I try to edit a source I just get a semi blank page. Source title in on page but the rest of the page is blank.

    I have disabled all plugins just to make sure there was nothing else conflicting with the plugin. Maybe a WordPress update has caused problems?

    Hi Eric. Cron jobs were stuck. All good now.

    Headed to leave a 5-star review now. Thanks for the support.

    • This reply was modified 4 months, 1 week ago by jpen365.

    Glad to hear that @jpen365.

    Thanks also for taking your time to write the reviews. We really appreciate that.

    Have a great day!

    Hi @websitehelperuk,

    Please try to follow the steps outlined on our Feed Items not importing page as suggested above. Please make sure to check your cron jobs as well if you think you have the similar issue.

    With regards to your other issue, yes, it could be caused by a theme or plugins conflict. If you still need further assistance with this, please open a new thread since it has a different topic.

    If you are using any of our premium add-ons, you can also open a premium support ticket.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.