Support » Plugin: Twitter Widget Pro » Feed not updating

  • Aaron — good to speak with you a moment ago.

    In early November, I updated this widget from a prior version because the old version was saying that Twitter couldn’t communicate with my website (or something along those lines). Then when I updated to the latest version, all appeared to work. Then a little time passed and I noticed that, while Tweets were displaying, it wasn’t updating at all – it still has the tweet I sent on 11/17 on top (and I’ve got lots of tweets since).

    Anyway, it’s not update lock/API usage issue. See this screen shot from my admin http://starboard.us/files/delete/twitterwidget.jpg.

    My website is http://starboard.us. It is running on an Windows platform. The source files I’m using are available here: http://starboard.us/files/delete/twitter-widget-pro.zip. They are the source files for the latest version, with some custom changes I made (all of them cosmetic).

    Can you take a look and maybe point me in a direction that might solve the problem? Thanks.

    http://wordpress.org/extend/plugins/twitter-widget-pro/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Do you have to use an alternative cron?

    No, not that I’m aware of.

    I decided to try to see if my modifications have any impact on the widget’s ability to update. So, I put a completely clean copy of the widget here (http://keepseniorssafe.com/test). As you can see (https://twitter.com/60PlusAssoc), it hasn’t updated since I put it there.

    So, now we know it is not my code modifications. This stuff is running on a Windows server (if that info helps).

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Try using the new version and authenticating your account. That should raise your rate limit. I know your limit doesn’t say it’s used up, but maybe there’s something weird about Twitter and your IP address.

    Okay — have successfully updated to latest version (2.5.3) and successfully authenticated. Update locks are clear. Still not updating since I did the version update.

    See: https://twitter.com/60PlusAssoc and note the most recent post there is not showing up at http://keepseniorssafe.com/test.

    Please advise. Thanks!

    Hi, same problem here. Feed hasn’t updated – one new tweet from 2 days ago doesn’t show up but previous tweets still displaying.

    Account is authenticated. Lists rate Usage and Statuses Rate Usage both show as:
    Used: 0
    Remaining: 180
    Limits reset in: 16 minutes

    Tried “Clear Update Locks” but response message says there were no locks to clear.

    Any ideas?

    The problem seems to have resolved itself.

    I think it must have been either a caching issue or Twitter has tweaked something that fixed it.

    I’m still having the problem, which can be confirmed by checking the links I listed previously.

    I have the widget set up here, latest version, set up and authorised app. [ link redacted ]
    All seems successful but it refuses to update.

    No locks to clear it says but no updates since I installed the App Auth version. Any ideas?

    Thanks
    Rob

    Rob_Che, have you resolved the problem yet? I’ve got the same issue. Research suggests it might be something to do with a php callback. Is the site hosted with Heart Internet by any chance?

    [ link redacted ]

    This is also happening on holyblossom.org. I just updated the plugin, and none of the tweets posted since then are showing up.

    See the homepage of holyblossom.org and its twitter page (https://twitter.com/holyblossom)

    Help!

    Having the same issue as well. I recently installed the plugin, and only the first tweets that initially loaded are showing up. Hasn’t updated since. I cleared the locks with no luck.

    Ended up ditching this plugin for TwitGet

    Alot more flexible, and no updating issues.

    Yeah, I opted for a different plugin too. Heart Internet advised me that the issue with Twitter Widget Pro is that it uses a callback which *could* present an infinite loop problem.

    Thanks HarryAdney, I’m with Heart too and thought it might be that the server was blocking a bounce between the services.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Feed not updating’ is closed to new replies.