Support » How-To and Troubleshooting » feed: is not a valid protocol ?!

feed: is not a valid protocol ?!

  • Hi all,

    I just notice that the links in WP – sidebar RSS and Comments RSS have something like:

    Now my browser gives a error message, is this common??

    ps I removed feed: from a href and now the links give me a good xml file.

Viewing 4 replies - 1 through 4 (of 4 total)
  • you’ve to remove the colon “:” sign.

    No, pretty sure feed:http... is correct, stchatterbox.

    DDT: The point of the feed: part is so that if you have a feed reader installed, clicking the link will automatically make it open / bookmark / whatever in your feed client.

    You can remove it if you wish – it doesn’t matter. I personally chose to remove it from my blog so that users who click the link in their browser and don’t have a feed reader installed that handles the feed protocol won’t get that error.

    tx guys for explaining this.

    I am trying to integrate WP in a website. I have got a seperate RSS page with all feeds (not just from my weblog).

    For the feed readers I thought using this
    <link rel=”alternate” type=”application/rss+xml” title=”RSS 2.0″ href= ….

    Would be sufficient?

    Well another thing learned today, tx.

    That’s only for browsers that support feeds (Firefox, Opera, etc.) and for feed crawling bots.

    Having an actual link to your feed(s) is always a good idea.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘feed: is not a valid protocol ?!’ is closed to new replies.
Skip to toolbar