Support » Plugin: AWS for WordPress » Feed is malformed and cannot be parsed. Please make sure that the feed is a vali

  • Ok so I am setting up Amazon AI plug in which should be simple LOL. I know a lot of people seem to be having issues but no resolution and I want to be complete in the information. First when I go to Alexa Skill Blueprint and start a blog still it give me the following error message:

    Feed is malformed and cannot be parsed. Please make sure that the feed is a valid RSS format.

    I have validated the url at http://www.feedvalidator.org and it is valid.

    I do have audio files and people can listen on the website but when I go to apple connect it doesn’t see any of my audio files. Not sure if these too issues are related but thought I would be complete.

    Also I have checked the S3 where the audio files are and they are there. so Not sure where there is an issue with that.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor tstachlewski

    (@tstachlewski)

    Hi @jaycova,
    Each problem is a bit different. In your case, everything seems completely fine 🙂 Till the point of RSS feed and the problem of not having information about audios there – in short, your RSS feed is empty. Usually, this is connected with the fact, that the owner of the blog didn’t convert any post/page to audio… but, in your case this is not truth… I have checked and you have got some audio files… Hmm.. Are you using WordPress pages or posts?

    Thank you for your explanation. Yes I am using Posts only and I do have audio available on my page.

    I just upgraded to the latest plugin. In case you were curious. I am also using safari for more browser.

    Plugin Contributor tstachlewski

    (@tstachlewski)

    Strange, really strange. I will investigate the problem next week – no worry, I won’t forget about you, I just need to figure out what might be the problem.

    Thank you and I really think this is something a lot of my clients would be interested in. So here are a question to think about.

    On the Alexa Blueprint when entering the url does it do some validation for the url beyond looking for the amazon-pollycast at the end? if not it should be a problem on the blue print but I did validate the link and it is good so not sure where is it malformed.

    Plugin Contributor tstachlewski

    (@tstachlewski)

    The problem is that Alexa Blueprint will also validate if there are any items (audio files) specified in the feed – in your case they are not. The other validation tool, which you have referenced before is not checking this – because it doesn’t care.

    Ok that makes sense. Also does it matter that I am using the AWS Marketplace Bitnami image of wordpress? I don’t know if that would make a difference.

    What I am hearing from you is that the blueprint isn’t seeing my audio files to validate which would make sense why apple connect is not seeing my audio files either.

    Hi Tomasz,

    I am adding my comment here because I just experienced the very same problem.

    I wanted to create my first Blueprint skills and this error message came up:
    Feed is malformed and cannot be parsed. Please make sure that the feed is a valid RSS format.

    My podcast URL is this: https://www.dragoman.ist/feed/amazon-pollycast/
    And it looks empty to me too although I had generated audio for nearly 100 posts before

    Can you kindly investigate this further

    Quick update:

    I was testing post categories on Podcast tab, deleted them and resubmitted my RSS Url to Alex, now it works.

    How can I specify post categories in my RSS feed or is it not supported yet?

    Tomaz

    I tried what Umit did above and I am still having issues. Do you have an update yet?

    jaycova

    (@jaycova)

    Has there been any update on this. I really would like to get this working.

    Hello Tomas

    Any updates?

    Hello

    So I updated the Amazon plugin again. I am still not able to make an alexa blueprint getting the same error again. Is this a dead issue and no one will ever work on it?

    Jaycova,

    If you have any post categories, remove them.
    Also uncheck explicit content. Your current RSS shows explicit tag. You cannot publich explict content on Blueprint.

    Umit

    Thank you but I have removed the tags weeks ago. so what am I missing. WordPress says there are no tags and everything is un catagorized. let me know if you need a screen shot

    I am checking your RSS right now and it says “explicit” YES
    Should be “no”
    You can change this on your blog and/or on your podcast host’s page

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.