Support » Plugins and Hacks » [Resolved] Feed is broken after update

[Resolved] Feed is broken after update

Viewing 8 replies - 1 through 8 (of 8 total)
  • Update- This fees url works http://www.principledpolicy.com/?feed=podcast

    This one does not work- http://www.principledpolicy.com/feed/podcast

    I have tried re-saving the permalinks but this does nothing. Tried disabling other programs- nothing. Any suggestions?

    OK, mysteriously the broken feed http://www.principledpolicy.com/feed/podcast now validates. But iTunes STILL won’t read it. And since it hasn’t read it for over 2 weeks we look like a dead iTunes link. What might this problem be?

    Plugin Author ntm


    You are right the validates. But this particular feed does not contain podcast episodes and no iTunes elements. It looks like podPress has been deactivated or something else (an other plugin) is preventing podPress from doing its job. On the other hand this feed exists. Which it would not if podPress would be deactivated.

    Is podPress active?
    Did you install new plugins or plugin upgrades (besides the podPress upgrade)?
    Did you change settings of theme or plugins?

    But iTunes STILL won’t read it.

    The iTunes server looks only once every 24h for updates which explains why updates in your RSS feed are not be visible on the iTunes page of the podcast immediately.
    Due to the missing podcast elements, iTunes can not find new material. That is probably also the reason why your iTunes page looks a little bit empty at the moment.

    The main question is: why are there no podcast element in this podcast feed?
    Because there is no setting in podPress which would have such an effect, I suspect that a different plugin (or a theme function) interferes with podPress. That is why I’m interested to know whether you updated other plugins too.

    Thank you for your response. I am deactivation everything except Podpress and a few other essentials to see if that is the problem.

    Where should I be looking in the RSS feed to see the iTunes elements?

    Never mind on that last question. I see them now. I believe that the culprit is WP E Commerce. Not sure yet, still testing but the plugin that has caused me the most grief has been this one. When I find out the bad player I’ll report here.

    After testing the bad player seems to be WP E Commerce. Any idea why this one might be interfering with your plug in (which has been an indispensable help to us in running our podcast)?

    Unfortunately, I need both plug ins to make my sight work. I’m going to post over there but, frankly, I might as well throw a coin in a wishing well as expect an answer from them. Their support STINKS!

    Plugin Author ntm


    Please, look into the sub folder wp-content/plugins/podpress/optional_files/podpress_wp_e-commerce_compatibility.
    This folder contain a little plugin. Copy that file into wp-content/plugins/ folder. Open the plugins page of the blog and activate it. (You may need to clear the cache of browser or feed reader program in order see whether something has changed.)
    Maybe leave it activated. I will take a look in an hour or two.

    If this plugin is not helping then please tell me the version of your WP e-Commerce plugin.

    OK, that fixed it! Thank you so much. This has been a problem for over 2 weeks.

    I’ll Make a donation ASAP! Podpress is great!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Feed is broken after update’ is closed to new replies.