Support » Plugin: Sermon Manager » Feed has blank line – breaks validation

  • Resolved McFarnell

    (@mcfarnell)


    When I try to validate my feed, there is a “Blank line before XML declaration”. This breaks the validation. I tried disabling Sermon Manager, and then my feeds work correctly. I’ve gone through and tried to find what is causing this blank line, but I can’t find anything. Anyone else have this issue or know of a solution?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Found the issue. Deleted “?>” at the end of the template-tags.php and that fixed it. I think this issue was caused by another issue that I had fixed, but it is all good now.

    @mcfarnell – Just to be clear, this isn’t an issue with the core plugin, but rather a change you made, correct? If I’m mistaken please let me know!

    Yes and No.

    My RSS feed did have a bunch of duplicate items, making the feed extremely long, and it wouldn’t validate. I followed @antgiant suggestion to change template-tags.php as follows.

    Currently if (is_archive() || is_search() ) {
    Change to if (!is_feed() && ( is_archive() || is_search() ) ) {

    That fixed the duplicate line issues (is this fixed in version 2.0.1?)

    However, that fix introduced the blank line at the top of the feed, which again caused it to not validate. I fixed this by removing the ?> at the end of the file.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Feed has blank line – breaks validation’ is closed to new replies.