Feed error: "The underlying connection was closed" (10 posts)

  1. SM05
    Posted 10 years ago #

    Hi all,

    Trying to refresh the feed in either RssBandit or Jet Brains O/Reader I get the same exact

    "The underlying connection was closed: An unexpected error occurred on a receive."

    error. I was able to subscribe to it and receive original the very first feed just fine. And I can see/read each post too.

    I have v1.5.1.2 setup on WinXP, PHP 4.1.12 and MySQL 5.0.3.

    Here's what I've done:
    * Installed WordPress locally
    * Manually re-entered contents from dasbLog to WordPress blog
    * Verified that it works locally
    * Created DB on the host server (Win2k3, same PHP/MySQL)
    * Using MySQL Admin exported tables and data and imported them on the server
    * Verified that I'm able to administer and read posts on the server

    I'm not sure what to do at this point or what to check. Is this some known WordPress issue or likely my web host's problem? In case of web host issue, what are the questions I should ask them?

    I'd appreciate any help. Thanks in advance.

    PS Here's feed for my blog if anyone would like to double check that: http://www.usysware.com/blog/?feed=rss2

  2. The error that you are quoting is a server issue, not a WordPress issue. For the record, your feed is working fun right now and is perfectly valid.


  3. SM05
    Posted 10 years ago #

    If you were to temporarily subscribe to my blog, do you get that or some similar error as well? Thanks.

  4. I will subscribe and let you know what happens in the next 3 hours.

  5. Well, I didn't notice any problems in the past 5 hours.

  6. SM05
    Posted 10 years ago #

    Thanks. What rss reader do you use? BTW, are you on Windows or not?

    A friend of mine and I tried it with RssBandit and JetBrains's O/Reader and both get the same error after several feed refreshes.

  7. I'm on a Mac and I used RSSOwl v1.1.2 (it's cross-platform).


  8. SM05
    Posted 10 years ago #

    Looks like this a problem with .NET 1.1 thus effecting all .NET based rss readers, such as RssBandit and JetBrains's O/Reader. Why is that only this WorldPress based feed is effected I have no idea. Thanks.

  9. SM05
    Posted 10 years ago #

    I take my .NET 1.1 comment back as I've tried to access other WordPress blogs w/o any problems. I do have .NET 1.1 SP1 installed on my pc. I'm back to wondering whether it's WordPress or host issue.

    Could someone with .NET 1.1 based Rss Reader and .NET 1.1 SP1 installed give it a shot and temporarily subscribe to my test feed please? I'd very much appreciate it.

    The temporary blog: http://www.usysware.com/wordpress/


  10. SM05
    Posted 10 years ago #

    After ruling out web host, .NET rss readers I turned back to WordPress. It was, and still is, a WordPress's problem after all. WordPress returns an invalid header on feed refresh. Apparently a patch for this problem has been checked in already: http://trac.wordpress.org/ticket/1425

Topic Closed

This topic has been closed to new replies.

About this Topic