Support » How-To and Troubleshooting » Feed Error in my WordPress site

Feed Error in my WordPress site

  • [Moved from Your WordPress which is NOT a support forum.]

    I am using WordPress 3.9.1 version on my new website http://www.goopro.org/

    But in feed url it shows me error


    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.goopro.org/feed/
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>

    Can you please suggest me what is wrong here. And how can I remove this error from feed url

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi


    Forum Moderator

    You have a blank line at the top of your feed file that is invalidating it. Possibly caused by a plugin or your theme. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    yes, you are right. This error is because of plugin which I have created custom.

    When I re-activated this plugin it shown me this error

    The plugin generated 1 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues,

    Do you have any idea what could be the reason of this error message.



    Forum Moderator

    Thanks, That worked..

    Thanks once again for your help. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Feed Error in my WordPress site’ is closed to new replies.