Support » Fixing WordPress » FEED error (_lastBuildDate)

  • Hello everybody, i can’t validate my rss feed. It’s showing some erros:
    line 15, column 47: lastBuildDate must be an RFC-822 date-time: qua, 28 dez 2016 19:16:53 +0000
    line 39, column 58: XML parsing error: <unknown>:39:58: not well-formed (invalid token)

    The feed address is is: sandrabastoscoach.com.br/feed

    I also try to fix it installing the rss fix erros plugin but no success.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    Sorry for my slopiness, i forget to to mention that it was the first thing i’ve done. But with all plugins deactivated and wordpress with custom theme it still receiving error messages in feed validator.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    What version (en, br, etc.) did you install? I’m looking for a pattern among the folks who’ve reported similar problems.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    OK, turns out it’s a bug that will be addressed in WP 4.7.1.

    See https://core.trac.wordpress.org/ticket/39141

    Oh yes! It’s really a version core trouble, i’ve solved the first problem (date) with the code above in functions.php:

    <?php
    add_filter(‘date_i18n’,’rssfeeds_date_donttranslate’,10,4);
    function rssfeeds_date_donttranslate($j, $req_format, $i, $gmt){
    if(is_feed())
    return date($req_format);
    else
    return $j;
    }

    And the “XML parsing error” was solved

    But unfortunately now i’m getting other error messages, cleary is something with the 2 last posts, i try copy the post content, create a new post with the same text but i keep receiving error:

    line 38, column 488: XML parsing error: <unknown>:38:488: not well-formed (invalid token)

    Well, by the way this problem of “not well-formed” feed is unsolvable.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘FEED error (_lastBuildDate)’ is closed to new replies.