WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Feed does not validate – can’t fix it – help!

[Resolved] Feed does not validate – can’t fix it – help!

  • donnylyn

    @donnylyn

    My feed is erroring on all my pages excepet the home page.
    In FeedMedic in Feedburner, I am getting a problem message:

    FeedBurner had trouble retrieving your Source Feed: http://homesteadorigins.com/?feed=rss2

    The error message is:

    Error on line 2: The markup in the document following the root element must be well-formed.

    I checked feed validator and this is what it says:
    Sorry

    This feed does not validate.

    *

    line 1, column 0: Undefined root element: br [help]

    *

    line 2, column 0: XML parsing error: <unknown>:2:0: junk after document element [help]

    <b>Warning</b>: ob_start() [<a href=’ref.outcontrol?PHPSESSID=08e27da4d8d2e …

    Source: http://homesteadorigins.com/?feed=rss2

    1.
    2. <b>Warning</b>: ob_start() [ref.outcontrol]: output handler ‘ob_gzhandler’ cannot be used after ‘URL-Rewriter’ in <b>/home/homeste5/public_html/wp-includes/functions.php</b> on line <b>419</b>
    3. <?xml version=”1.0″ encoding=”UTF-8″?>
    4. <!– generator=”wordpress/2.2.1″ –>
    5. <rss version=”2.0″
    6. xmlns:content=”http://purl.org/rss/1.0/modules/content/”
    7. xmlns:wfw=”http://wellformedweb.org/CommentAPI/”
    8. xmlns:dc=”http://purl.org/dc/elements/1.1/”
    9. >

    Help! How do I fix this? I have not been able to locate this code to be able to change it so that it’s acceptable. What do I do? And How do I need to change this so that I stop getting this problem message?

Viewing 2 replies - 1 through 2 (of 2 total)
  • donnylyn

    @donnylyn

    In my first post, the lines didn’t copy as they appeared in the error message. My blog is http://www.HomesteadOrigins.com

    [Moderated} Please try posting your code for view via http://pastebin.com.
    Unfortunately, it is breaking the forum in the way it has been presented. Thanks

    the code goes on with the posts from the day…
    http://homesteadorigins.com/?m=20070930

    How do I find this code so that I can fix this? I host my blog on Blue Host, and I can’t find the code there. What do I need to fix this? Help!

    donnylyn

    @donnylyn

    here’s the fix, thanks to Steve who authored the Feedburner plugin.

    Turn GZip off in WP-Admin.
    You will find this in Options>Rearding – go to the bottom of the page and uncheck the box for the statement
    “WordPress should compress articles (gzip) if browsers ask for them”

    Thanks Steve!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Feed does not validate – can’t fix it – help!’ is closed to new replies.