Support » Plugin: WP Content Security Plugin » FEATURE:Please add upgrade-insecure-requests; report-uri options to next version

Viewing 1 replies (of 1 total)
  • A quick hack to add the “upgrade-insecure-requests;” option in your CSP for now is to modify line 165 on /includes/wpCSPclass.php from this

    $CSPOutput .= "report-uri " . $ReportURI ;

    to this

    $CSPOutput .= "upgrade-insecure-requests; report-uri " . $ReportURI ;

    • This reply was modified 2 years, 8 months ago by  .
Viewing 1 replies (of 1 total)
  • The topic ‘FEATURE:Please add upgrade-insecure-requests; report-uri options to next version’ is closed to new replies.