Easy Related Posts
[resolved] Featured thumbnails are broken, only if 'crop thumbnail' is selected (7 posts)

  1. oliverh
    Posted 3 years ago #

    Ver. 1.4.1 of ERP. Works great if you just deselect 'crop thumbnail', but I'd like them square or rectangular, if possible.

    I tried un/reinstalling, that didn't fix it. I don't want to regenerate my thumbnails, but I will if I have to.

    I have also tried changing the theme and resetting the permalink structure. None of that worked.

    Thoughts, ideas?


  2. xdark
    Plugin Author

    Posted 3 years ago #

    This must be the cache bug again, please check this thread and report back to me.

    PS regenarating thumbs won't work cause thumbs are generated dynamicaly.

  3. xdark
    Plugin Author

    Posted 2 years ago #

    No response for 2 month so marknig this as resolved

  4. oliverh
    Posted 2 years ago #


    I'm still having the same issue. I just checked tb.php in the /inc/tim forlder and it's set to false (the caching). I'm not using the wp-cache plugin, though I am using EM object cache, which only caches objects.

    When I set the thumbnail to hard crop, it invariably shows a broken image. If I turn off cropping, it's fine.

    Any thoughts?

  5. oliverh
    Posted 2 years ago #

    So I looked into this a little closer.

    You can see the problem here: http://www.positivebias.com/a-dog-and-her-ball/

    The link that is being auto-generated for the image URL using the tb.php script looks like this: src="http://www.positivebias.com/wp-content/plugins/easy-related-posts/inc/tim/tb.php?src=vebias.com/wp-content/uploads/2013/07/wpid-CAM00313.jpg

    So what is happening is the script is truncating my domain name by 6 characters, lopping off 'positi' or 'www.positi' from the front. I'm not sure what would do that; I'm reasonably adept at PHP but I don't want to start messing with it. Can you take a look?


  6. xdark
    Plugin Author

    Posted 2 years ago #

    Hi Oliverh,

    Actually the image is generated through an object so it could be EM object cache plugin too...

    Could you please try:

    1. Disable cache plugin
    2. If you are running on a linux server make sure that wp-content/plugins/easy-related-posts/inc/tim/cache folder is writable (755)

    Please provide feedback if this fixed thumbnails issue.

  7. xdark
    Plugin Author

    Posted 2 years ago #

    Resolved as for version 1.5.1. Please confirm it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Easy Related Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.