Support » Theme: Shoreditch » Featured post image does not show on blog page

  • Resolved Andrzej

    (@ukandrzej)


    I have used a featured image on a post ( http://bit.ly/2mjCBf7 ) – and that shows up fine. I have given it a tag called Featured so that it also shows up on the blog page at the top (it’s the second featured post). On the blog page the post shows up – but the featured image is missing.

    Once I get this going, would someone be able to advise me on what CSS I could use to remove the grey overlay on the blog page – I have successfully removed the overlay on the single post.

    This is the configuration in the customiser:

    Blog Display

    Full post – not ticked
    Post excerpt – ticked

    Author Bio
    Display on single posts – ticked

    Post Details

    Display date – ticked
    Display categories – ticked
    Display tags – ticked
    Display author – ticked

    Featured Images

    Display on blog and archives – not ticked – tried ticked, no difference

    Display on single posts – ticked
    Display on pages – ticked
    Automatically use first image in post – not ticked

    Grateful for any help.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have solved part one of this. I’m afraid I had some CSS in the child theme that was causing the background image not to show.

    If it is possible to remove the grey overlay with CSS on the blog page, I would be grateful for that information.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    @ukandrzej – I’m not sure where to find the grey overlay you’re referring to on this page – https://www.wimbledonvisitor.com/news/

    Could you provide a direct link here and I’ll be glad to take a look.

    On the blog roll page – http://bit.ly/2maPIOE – there is a featured post slider that has two featured posts together with their featured images. The featured images in the featured posts slider are slightly darker than the ones on the actual posts. On the individual posts I have removed the grey overlay like:

    /* Remove image overlay over featured image */
    
    .entry-hero::before {
      background-color: transparent;
    }

    That makes the image brighter on the actual posts page, but still makes the images darker on the blog roll page featured posts slider.

    As for the rest of the posts on the blog roll page, I have successfully made the featured images lighter by adding this to my child CSS theme:

    /* On blog roll page remove dark background overlay from featured images */
    
    @media screen and (min-width: 1020px) {
    .entry-hero::before,
    .site-content-wrapper .has-post-thumbnail .entry-header::before {
        display: none;
        }
    }

    What I am trying to achieve is to target the blog page (in my child theme) with the above CSS, so that the featured images in the slider have the same brightness as those on the individual posts.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    @ukandrzej Thanks for the clear explanation!

    Give this a try:

    .featured-content .hentry.has-post-thumbnail::before {
      background: rgba(0, 0, 0, 0);
    }

    Thank you very much. It worked perfectly!

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Great! I’ll mark this thread as resolved but feel free to start a new one if you need help with anything else.

    Hi,

    I am creating a new theme, everything works fine, except the blog section.
    I would like to show date, author, category, tag, reply everything under the
    post title. Can you help?

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    @shamsrobeen – this thread is about a specific issue in the Shoreditch theme, which is resolved.

    If you need help creating a new theme, please start a new thread here:

    https://wordpress.org/support/forum/wp-advanced/

    To point you in the right direction, I’d suggest you begin developing with a starter theme like Underscores rather than starting from scratch.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Featured post image does not show on blog page’ is closed to new replies.