Support » Theme: Storefront » Featured Images uploading to gallery but not able to be assigned to products.

  • Resolved eaec

    (@eaec)


    Hello all, first post here. I am having an issue with my Woocommerce site. I have previously had no problem assigning featured images to products, but since March 6th, my images will upload to the gallery, but will not assign to products.

    I am using Woocommerce 3.2.6 currently, this has not changed since the issue arose.

    Other plugins I am using:

    Advanced Woo Search, Akismet Anti-Spam (deactivated), Canada Post Shipping For WooCommerce Premium, Currency Switcher for WooCommerce (deactivated), DiscPress PRO (deactivated), Enhanced E-commerce for Woocommerce store (deactivated), Exclude Pages From Menu , Jetpack by WordPress.com (deactivated), Limit Login Attempts, Storefront Header Picker, Storefront Sticky Add to Cart, WooCommerce Auto Restore Stock, WooCommerce Cost of Goods, WooCommerce Extra Product Sorting Options, WooCommerce Filter Orders by Product, WooCommerce Payment Gateway Based Fees, WooCommerce PayPal Express Checkout Gateway, WooCommerce PDF Invoices & Packing Slips , Woocommerce Products Per Page,
    WooCommerce Services (deactivated), WooCommerce Social Login (deactivated), WooCommerce WishLists, WP Time Capsule.

    Is there any chance one of these is causing the issue? I just updated all plugins that had updates available aside from Woocommerce itself, to avoid potential version conflicts between the core plugin and others that are not yet sertified to work with 3.3.3.

    System status report is here: https://pastebin.com/dtjZ2mf5

    Thanks in advance, other comments on my setup are welcome as well.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Mikey Arce

    (@mikeyarce)

    Automattic Happiness Engineer

    Hi @eaec,

    My first suggestion would be to disable all your plugins except WooCommerce and switch to a default theme like Twenty Seventeen to see if you can upload featured images again.

    If the problem goes away after doing that, try enabling everything back to see where the issue was.

    Thread Starter eaec

    (@eaec)

    Hi @mikeyarce,
    Thanks for the reply – I am able to upload, but not to assign to products, in case that makes a difference here – but, will my customizations remain intact if I switch my theme back and forth like that? I don’t have a child them set up currently so I am hesitant to make a drastic change like that without knowing what could happen.

    • This reply was modified 3 years, 3 months ago by eaec.
    • This reply was modified 3 years, 3 months ago by eaec.
    Thread Starter eaec

    (@eaec)

    I thought I would share in case anyone else encountered this issue, I disabled the plugins as suggested by @mikeyarce above and then re-enabled them one at a time while uploading images and discovered the culprit was the PayPal payment gateway plugin. I did not have to change the theme to get it to work. Thanks for the help!

    Thread Starter eaec

    (@eaec)

    Resolved!

    Help us as well if you do not mind, same issue after last update I see all image in upload folder but when I try to add product image nothing happens. And yes Paypal express did the trick. Thank You dude , life saver .

    • This reply was modified 3 years, 3 months ago by spaha.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Featured Images uploading to gallery but not able to be assigned to products.’ is closed to new replies.