WordPress.org

Ready to get started?Download WordPress

Forums

Superhero
[resolved] Featured Images not working in general (7 posts)

  1. maggiegram
    Member
    Posted 9 months ago #

    Hi all,

    After a recent update (either to WordPress or to the Superhero theme, I'm afraid I can't recall which), my featured images stopped working entirely, both on posts and on pages. I'm wondering whether anyone might have suggestions as to how I might have messed this up. My site is at http://www.maggiegram.com. I'll be very grateful for any help.

    Thank you, thank you!

    Maggie.

  2. designsimply
    Member
    Posted 9 months ago #

    I tested Superhero version 1.1.5.1 with WordPress 3.9.1 and I was able to get featured images working as expected. For reference, here's a page from the Superhero demo site showing how a featured image should look:
    http://superherodemo.wordpress.com/2013/01/08/featured-image-post/

    In your case, I think it would be good to start with basic a troubleshooting step.

    If you temporarily switch to another theme that uses featured images, such as Twenty Fourteen, do they work properly in that theme? This would help double check that featured images are indeed setup on the post or page you're thinking of and also rule out an issue with featured images in general.

  3. maggiegram
    Member
    Posted 9 months ago #

    Thanks so much for this. When I switch to Twenty Fourteen, the featured images do indeed work. But when I switch back, they disappear again. Any thoughts on where to go from here?

    all the best, M.

  4. designsimply
    Member
    Posted 9 months ago #

    That's a great first step. It tells you that featured images are working both in your WordPress install and for the posts where you expect them to work.

    I think I found the issue! At least in my testing, I found that if I enabled the Jetpack Photon module then the featured images disappear.

    Do you have Jetpack installed? If you do, can you try going to Jetpack > Photon > Learn More > Deactivate and check to see if the featured images work normally after that?

  5. maggiegram
    Member
    Posted 9 months ago #

    Genius! That was it! Thank you so much; I really appreciate your help.

    all the best,
    Maggie.

  6. designsimply
    Member
    Posted 9 months ago #

    Great! But also, awwww. Photon should work too! I've filed a bug report to see if someone can take a look. In the mean time, switching off Photon sounds like a good, temporary fix.

  7. Caroline Moore
    Member
    Posted 7 months ago #

    Howdy! Thanks for bringing this bug to our attention.

    There's a fixed version of Superhero here that should work with Photon:
    http://public-api.wordpress.com/rest/v1/themes/download/superhero.zip

    It will be available here on WordPress.org soon!

Reply

You must log in to post.

About this Theme

About this Topic