Support » Plugins and Hacks » [Resolved] Featured images not showing

[Resolved] Featured images not showing

  • Hi,

    This looks like a great plugin – thank you for sharing.

    However, one of the main reasons I downloaded it, was to upload featured images from within the CSV.

    Unfortunately, this is doing everything but that one task. I have checked all the paths and they are as they should be, but no image actually shows.

    Has anyone else had this problem?

    I could really do with some help on this – please – anyone?


Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author smackcoders


    Can you attach a sample csv for further help?

    Hi @smackcoders,


    However, I worked out that it was a permission issue.

    It is working perfectly now.

    Plugin Author smackcoders


    Thanks for the update

    Maybe you could provide some more information about your solution, since others (like me) have the same problem.

    Which folder did you change permissions from that fixed your issue?

    Plugin Author smackcoders


    Your wp-content/uploads folder must be writable. If not change the permission.

    Hi. I’m still having trouble with the Featured Image for a Product type. My folder permissions are all Writable (777), including wp-content, uploads, and a folder I created called “products”. Everything works great except the Feature Product image does not show. I’m using WordPress 3.5.2. Any help or insight?

    I found that mine would not work unless I included the full path in my spreadsheet. For example:


    Plugin Author smackcoders


    @jamesict, Yes exactly. The featured image should be mentioned as full url path and should be writable . In general it can be also an external domain url path where you can upload all your images that are to be mapped before importing the content. This is an easy simple process comparing to importing images to wp media and setting it as a featured image one by one.

    Also ensure that these images exists and downloadable. Otherwise it crash the import with an “warning: copy() [function.copy]: unable to access”

    Thank you all for the feedback. I was using the full path and still having the problem. To ensure the path is correct, I pasted the url into a browser and it displayed the image correctly. Still a mystery as to why the Featured Image is not appearing. If anyone else has ideas, I would appreciate it! Thanks again.

    Plugin Author smackcoders


    @jhample, can you provide the link of an image that not importing? Also check your media folder have the image imported.

    Sure. The full path to the image is: http://s166042.gridserver.com/wp-content/uploads/products/high-res-BRYANT_SQUARE_PETITE_featured.jpg

    Which I have in my CSV. This is for a MarketPress product, so I am mapping to the “CF: mp_file” field. As I mentioned, all the data works GREAT. Only missing piece is the Featured Image. All folders in the path have write permissions.

    Plugin Author smackcoders


    @jhample, as from recent testing in our live demo the featured image was imported with success. Kindly refer this test import link http://demo.smackcoders.com/demowptwo/?p=1443. But it is default wordpress post not the marketpress or custom field. Just import the image with normal post and check.

    So the final conclusion is there is no issues with folder permission or full url path. Only the reason that how marketpress handles the featured image as custom fields.

    Thank you for the prompt replies! Yes, I see your point. I’m wondering if you or anyone else might have a solution or know what MarketPress calls a featured image so that I can use a custom import field. My client will have thousands of products and I want to be able to import all, with featured images at the same time. MarketPress is a popular eCommerce solution so if anyone has an idea how to resolve this, it will help me greatly … and maybe others as well. Thanks!

    Plugin Author smackcoders


    You can expect this to solved in future versions, but i am not sure with the timeline. Because we are already engaged with a set of features that are already in pipeline. Any how i am adding this in our tracker. Thanks again for the suggestions.

    This topic is closed and users can start a new thread for proper tracking.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Featured images not showing’ is closed to new replies.