Featured Images not Displaying on Facebook Links (8 posts)

  1. MelanieTheRep
    Posted 2 years ago #

    I have researched for hours, and I am very frustrated. I can't get pics (which are checked as feature images in my posts) to display in Facebook links. I have both Jetpack and Easy Facebook Share Thumbnail. I've read numerous support threads and they're all too technical for me to understand. The links either feature the pic from my page's header or random pics from the post.

    I just started my blog a few days ago, so everything should be current. Maybe I added to many plug-ins on my own?

    Please help.

  2. Elio Rivero
    Posted 2 years ago #

    Hi Melanie, please try using the Facebook linter to see if Facebook can correctly parse the data in your page:

    1. copy a url from your blog, preferably, a single post, since the home poses different issues

    2. go to
    and paste your URL in the field

    3. click the Debug button and see if Facebook can obtain the featured image from your site

    If it can't be found, you'll receive a meaningful message. To further help you debugging, it would be useful to know the URL of your site, can you post it?

  3. MelanieTheRep
    Posted 2 years ago #

    Thank you so much for responding! I enter this:

    Apparently I have multiple og:urls

    Object at URL 'http://whattherepshoulddo.com/amanda-bynes-a-joker-2/' of type 'article' is invalid because it specifies multiple 'og:url' values: http://whattherepshoulddo.com/amanda-bynes-a-joker-2/, http://whattherepshoulddo.com/amanda-bynes-a-joker-2/.

    I have Jetpack, but I didn't know what that was and installed a few plug-ins. Maybe that's the problem?

  4. MelanieTheRep
    Posted 2 years ago #

    This is the list of Plug-ins I see. Perhaps some are redundant and competing with each other?

    Custom Link Widget
    Easy Facebook Share Thumbnail
    Go Daddy Quick Set Up
    Proper Custom Avatars for 3.5
    Rotating Tweets (Twitter Widget and Shortcut)
    Welcome to WordPress
    WordPress Stats View Counter
    WP Stats


  5. Elio Rivero
    Posted 2 years ago #

    Melanie, try deactivating Easy Facebook Share Thumbnail since Jetpack already includes open graph tags. That should solve the duplicate tag I see in your page.

  6. MelanieTheRep
    Posted 2 years ago #

    Deactivated. No Luck. I still see the pic from my header and not the featured pic I checked in the post.

  7. Elio Rivero
    Posted 2 years ago #

    I can see it's working as intended now. The Facebook debugger now throws only a warning about the image size and not an error like before.

    Please note that in order for the image to be collected by Facebook, it must be written to the page. If it's not in the page, it won't be captured by Facebook. I don't see a featured image in your post, hence, Facebook won't see it either.

  8. GuerrillaGallivanter
    Posted 1 year ago #

    Also having the same problem after a lot of research. New plugins are not working.

Topic Closed

This topic has been closed to new replies.

About this Topic