Support » Plugin: Blog2Social: Social Media Auto Post & Scheduler » Featured Images Not Appearing on Twitter..?

  • Resolved AndyBaines

    (@andybaines)



    I’ve been looking into Blog2Social on and off for a while, the first time I tested it I swear the feature image came up on Twitter but trying again twice this week has resulted with no image in the tweet.

    Is there anything I can do to see if this is a bug please..?

    Thank you 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Blog2Social-Support

    (@blog2socialsupport)

    Hello @andybaines,

    thanks for reaching out! From what you are describing I am most certain that it must be related to missing open graph tags in your posts META data. When sending out link tweets to Twitter the network automatically scrolls the META data of a webpage and generates the link preview with title, excerpt and image itself. In order for Twitter to be able to do this, its needs the respective tags e.g op:images or og:description.

    Whether open graph tags are automatically set can vary from theme to theme. You copuld either set them yourself by editing your HTML or simply apply another plugin which will do the job for you. We recommend either using Yoast SEO or OG.

    Since our last update, you can choose between two diffferent post formats for Twitter. Either the link format or the image format. If you choose the link format and have set open graph tags your tweet will automatically show your posts featured image. If you choose the image format (either in your B2S settings or right there in your posts preview) you are able to select a specific image.

    Just for making sure your issue is indeed related to missing open graph tags, please try to send out an image tweet and see whether the image is displayed. If not, you might also want to check your .htaccess file and make sure you have not activated any hot link protection.

    You are also welcome to contact us via e-mail at customer-service at blog2social dot com.

    Best regards!

    I’m having the same problem and it only started since the new version. It was working fine before

    mine is the image format and yet it’s not showing images on twitter

    I’ll test this again this evening and document my steps.

    Plugin Author Blog2Social-Support

    (@blog2socialsupport)

    Hi you two,

    thank you for reaching out!

    @steeltape could you contact us via email at customer-service at blog2social dot com. We have already released V4.1.1 fixing a bug for Twitter. However, it will be easier for us to resolve the issue for you if we can have a look at you website and twitter account. So it would be great if you could send us a mail with a link to both a blog post or pages you shared as image tweet and the respective result online on Twitter.
    Thank you in advance!

    @andybaines great! I am curious what you find out. If you’d like us to provide in-depth support and take a look on your website, please also do not hesitate to send us a mail!

    Best regards.

    This is what I’m seeing when arranging the post…

    Blog2Social 01

    …this is how it turns out on Twitter…

    Blog2Social 02

    …to me it looks like it’s chosen a valid image (The featured image.) I just realised, it worked fine posting to FaceBook yesterday using your plugin..?

    Blog2Social 03

    Any tips or suggestions would be appreciated. 🙂

    • This reply was modified 1 year, 7 months ago by  AndyBaines.
    • This reply was modified 1 year, 7 months ago by  AndyBaines.
    Plugin Author Blog2Social-Support

    (@blog2socialsupport)

    Hi @andybaines,

    thanks so much for the screenshots!
    I have also checked your websites sourcecode and it confirmed my previous guess that you have not set the neccessary open graph tags in your meta data. Please, try to do so by following the advise that I have given you in my first reply. Twitter needs the tags og:image, og:title and og:description to generate a link preview.
    If in doubt, you could uninstall and reinstall the plugin which would set your default post format for Twitter back to image tweets. For posting to Twitter with a focus on images you do not need the respective og tags in your meta data.

    Best regards!

    Hi,

    Deleting and reinstalling the plugin didn’t seem to solve the issue…

    https://i1.wp.com/i.imgur.com/LQHAwVs.png

    …I’ll try the instructions above but I’ve spotted that the plugin auto selects the largest version of the image, not a smaller one, I think it’s possible that it’s larger than Twitter allows..?

    Andy

    Plugin Author Blog2Social-Support

    (@blog2socialsupport)

    Hi @andybaines,

    just wanted to let you know, with Blog2Social 4.3.2 we have integrated an OG and Twitter Cards Meta Tag feature which helps you set the right meta tags in order for your posts to appear correctly on Facebook and Twitter. Please update and check in your Blog2Social Settings under the tab Social Meta Tags, whther you have activated the feature.

    Happy sharing and best regards!

    I was happy to hear this, I updated and enabled both options but still the image doesn’t seem to load on Twitter.

    I have the same problem. I can see the proper image in the B2S Twitter preview. But when I upload the post to Twitter I get a blank grey space where the image should display.

    Images upload fine to Facebook and Medium. Just not Twitter.

    As you can see in the Twitter feed above it recently started working. I uninstalled and reinstalled the plugin, started the 30 day trial, chose the option to “reset all page and post meta data” from the Blog2Social settings under “Social Meta Data” and tested a new post, I was really happy with the outcome and will deffo buy the plugin if they respond to my more recent support ticket of not being able to add a second Facebook page, however that is not relevant here.

    Andy 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Featured Images Not Appearing on Twitter..?’ is closed to new replies.