Support » Fixing WordPress » Featured images not appearing

  • Resolved lizardiswriting

    (@lizardiswriting)


    So I’ve been struggling with this problem for a few weeks now. I’ve deactivated and reactivated every plug-in AND tested my theme to see if that was the cause (and it was not) but for some reason most of my featured images are not showing up and it’s terribly annoying since it messes with the way my posts appear on my blog.

    I’m considering leaving WordPress if this does not get resolved soon.
    The featured images on my blog will not appear. They can be uploaded and edited. I’ve rebuilt their thumbnails. They are just fine until I attach them to a post and then they won’t show.

    The problem is when I set a featured image. I can click on an image I uploaded, but it won’t actually attach to the post. After I select a featured image, it says “Click the image to edit or update” or “Remove Image” but there isn’t a picture there and when I update or publish the page, still no picture. This isn’t the case across the board and I have no idea why about six pictures have worked and the others haven’t. I’ve resized them to be the same size, same picture quality, even similar names. I’ve tried it all. I don’t know what’s wrong.

    How do I fix this?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Still no progress.

    It’s probably a javascript error. Open Google Chrome browser and press Ctrl+Shift+I. The developer tools will open. Then try to attach a media as a featured image. Probably an error will show into the Console tab of dev tools. If that doen’t give you a hint, take a print screen and share here the link.

    I do know that you’ve already tested your plugins and theme, but the chances of this is a WordPress problem are minimal. To test again you can try the Health Check plugin. With it you’ll may disable all your plugins and switch to a bundled theme without affecting the site behavior for other users.

    Also, as per forums guidelines please don’t try to bump your post. Actually this reduces the chances of getting help.

    Oh my gosh, you are a life saver! Health Check found the problem.

    Please elaborate on what Health Check found… what was the problem?
    Thanks

    Yes, please elaborate! I just downloaded and used health check and I coulnd’t find anything wrong, but my featured photos still won’t show

    tobioluwatoyin

    (@tobioluwatoyin)

    I think my own issue came from jetpack.. You might have featured images disabled On jetpack.

    Go to jetpack and enable featured image.

    Thats the easiest solution. Let me know it helps.

    baltaru

    (@baltaru)

    Jetpack was a good lead.
    I had the same problem, althoug the site showed some or all the featured images after a few refreshes.

    I just unchecked the “Activate lazy loading for images” and the problem solved instantly for me.

    Jetpack was the cause for my site. Once i disabled lazy images, my featured images reappeared. It’s in the Settings > Performance > Lazy-loading images section

    Many thanks to everyone on this thread!

    The problem in my case was also traced to Jetpack. I disabled lazy loading of images and made sure featured images were enabled.
    Not only was it blocking featured images, but images within posts, and even paid-for banner images! All back to normal now.

    THANKS!

    My problem is only with an entry, I do not load the Featured image. Install the plugin “Health Check & Troubleshooting” that disables all the plugins, but the problem still persists. Re-install the wordpress and even then, it does not work for me.

    Hello, maybe this will help someone! After trying all the suggestions above, I discovered that I had turned on the Gallery option in the Format panel by mistake. When I changed the format back to Standard, the featured images appeared again.

    It’s in the panel that says:
    Format
    Standard
    Video
    Audio
    Quote
    Gallery
    Link

    • This reply was modified 3 months, 3 weeks ago by  kaymoco.

    Wow! What worked for me was to click the pencil to edit the blog post. Then click the gear icon in the upper right. Scroll down to “featured image” and click to choose the image. Save and voila!

    I am having the same issue but only with a select handful of images. I have tried everything mentioned and nothing is fixing this issue. I don’t use jetpack and the weird thing is that I have 130 other images and they all appear on the page and they are sized the same. I have pulled up the developer tools and can find no errors.
    The Health Check is not finding any issues as well. Very perplexed and frustrated as to why only a handful of images would not show.

    shentiaspirit

    (@shentiaspirit)

    I have the same problem but after unchecked Lazy Load For Images from Styling Settings, everything is working fine.
    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.