Support » Fixing WordPress » Featured Image Works Here, Not There

  • Resolved Kilroy 1944

    (@kilroy-1944)


    I’ve got a unique featured image assigned to every single page on my site, however, on several pages, the assigned image is replaced by the default header image. I’ve double, triple, and quadruple-checked all of these pages, to ensure that they’ve all got their own unique featured images set, but several of them refuse to display the featured image, and display the site’s default header image instead.

    Any ideas?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You should have something like this in your wp-content/themes/functions.php:

    // This theme uses a custom image size for featured images, displayed on "standard" posts.
    	add_theme_support( 'post-thumbnails' );
    	set_post_thumbnail_size( 624, 9999 ); // Unlimited height, soft crop
    }

    or

    add_theme_support(‘post-thumbnails’);

    I tried adding “wp-content/themes/functions.php” to my URL but I was given an error. I’m afraid I’m not familiar with the other information you posted. My site is a free “.wordpress.com” site and is all controlled from the website. Is there somewhere on the site/settings I could go or something I could do to make the site display the assigned featured images?

    You need to be on the WordPress.COM forums here: http://en.forums.wordpress.com/

    These here are for self- hosted sites only-not the same but easily and often confusing!

    Weird! Thanks for sending me in the right direction.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Featured Image Works Here, Not There’ is closed to new replies.