Support » Fixing WordPress » Featured Image URL redirects back to home page

  • nogi

    (@nogi)


    I have a problem with publishing my posts to Facebook where the featured image is not being displayed. I am using Jetpack and have also tried a direct URL paste with the same result.

    The og:image tags are working but the odd thing is that when you put the URL it gives into a browser it redirects back to the blog home page. If you go into the media manager and check the URL it matches and is correct.

    Now, if I go back into the media manger and then click on “Edit more details” and click update or open the permalink and then the image it seems to fix the issue.

    I have absolutely no idea on where to start to fix this issue?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Vishnu

    (@bukge)

    If you are already using WordPress SEO by Yoast plugin, then go to your SEO » Permalinks options page. All you have to do is uncheck the box next to “Redirect attachment URL’s to parent post URL”. This will redirect users arriving at attachment pages

    nogi

    (@nogi)

    Hi, yes I am using the Yoast plug in but that option isn’t ticked?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Featured Image URL redirects back to home page’ is closed to new replies.