Support » Plugin: FakerPress » Featured Image still missing

  • Resolved Shoofly Solutions

    (@nomadcoder)


    I have updated to the new version. The featured image is still not being generated and instead, a broken image icon is showing up.

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Gustavo Bordoni

    (@bordoni)

    Uhnn, I am super sorry about that @nomadcoder.

    Would you help me debug this further? I want to pin point if was a bug introduced in the plugin or if there is a Problem on the way I am using the WordPress methods.

    Can you check if you can Upload Media correctly to your WordPress?

    If that works, can you also try to go back do FakerPress version 0.4.1?

    Last check; Do you know if your server can download files using wp_remote_get()? If you don’t know it’s ok too.

    Thanks for reporting this problem, I will start debugging here too.

    I think that you may have hit on the problem. I can upload but I can only upload images below 1 mb. I’ll increase that and give it another shot.

    wp_remote_get should be working, but we did have some changes to the server recently. I will get back to you on that later.

    It turns out that the multi-site has it’s own settings for upload size, which I increased. I am now getting a timeout error so it looks like it’s our issue, not yours. I will come back and close this once I get that squared away. Thanks!

    Unfortunately, I was unable to resolve the issue. I tried on a single site that is on the same server. Although an image file is created in the uploads folder it is almost always corrupt. We did get a couple of complete images. There is nothing in the error log to indicate that anything went wrong.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Damn, that is a problematic answer, we could possibly be hitting the maximum size for a GET request, which can happen when trying to download images from outside sources;

    For PHP.ini config these settings could be the problem:

    • upload_max_filesize
    • max_input_time
    • memory_limit
    • max_execution_time
    • post_max_size

    Then depending on if you are using NGINX or Apache, you could run into a different set of configurations, that would prevent that from happening.

    Can you try checking these variables on your server config?

    I did update the .htaccess file and the settings and was able to upload some large images. I won’t be able to do more until Friday or Saturday and will double check those settings on the server. I will also test it on a host on another server.

    We are using Varnish + Apache and that could have an effect on the timeout but I’m not getting any error messages in the log or on the network tab.

    Does your code catch and report errors?

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Mostly the same as what WordPress does with wp_remote_get, but I am looking into adding some error_log into the fetching of images to allow folks to debug situations like this one.

    Hi, we were able to get it working consistently but only with Unsplash at Weight 10 (which is probably fine) or with the other services using a smaller image size. We had to raise post_max_size and upload_max_filesize both to 800M.

    I use your plugin all of the time and I think that it would be great to have some error information, maybe a debug checkbox. I would be happy to test it for you.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Thanks @nomadcoder,

    I will for sure add a Debug checkbox for us to have more information.

    I’ve tried in two different hosts using Apache and Varnish, and it wasn’t triggering any problems. =(

    Will keep this Topic in mind when I add this checkbox, it will require some time, due to having to add the Debug method calls.

    Maybe it would be worth (for you now) trying to log everything into one log file, E_NOTICE level. So we can try to see if there is any problems happening.

    Thanks for reporting,

    Why has this topic been marked as Resolved? Inline images are showing, but nothing for the Featured image besides its alt text.

    It seems to be working now. Specifying range sizes needs to be entered in first. I assumed the field placeholder sizes were the default if numbers were not entered?
    https://cloudup.com/cmq0HU2OoLY

    @gustavo Bordoni, adding form validation or default sizes would be a big help. Thanks!

    • This reply was modified 2 years, 2 months ago by polyfade.
    • This reply was modified 2 years, 2 months ago by polyfade.

    I did add a plugin that pulled the first inline image as a featured image for the ones that didn’t work. There seems to be a lot of fiddling required to get it to work properly and I would have liked to use larger images while generating a featured image. But I was ultimately able to generate what I needed.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Hi @polyfade and @nomadcoder,

    Yeah I will add more validation around the forms for FakerPress.

    On Modern Tribe (company I work for) we created a validation tool for Forms, and we are almost at the point where I will be able to use it here on FakerPress.

    My best regards,

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Featured Image still missing’ is closed to new replies.