Support » Fixing WordPress » Featured image on page not possible??

  • Using the 2012 Theme and trying to set a header image on a page that’s different than the header image that appears by default.

    When I edit that page and click on “Featured Image”, follow all the prompts and select the image I want, it does not work. The new image shows up in the featured image area in edit view, but when I browse to that page, I’m just seeing the same header image that’s on all of the pages.

    Obviously different pages need different header images, so I expect I’m missing something pretty simple?

Viewing 6 replies - 1 through 6 (of 6 total)
  • I can’t be the only dummy that can’t get this to work??

    Do you have any caching on your site or server? Try clearing those. Also posting a link to your site would be useful to anyone helping you.

    Doesn’t look like a caching issue as I get the results with multiple computers/browsers.

    I guess part of the problem is my description and perhaps “Featured Image” is not what I’m having a problem with. To clarify– given a very simple site with say, 4 pages. I can go into Appearance options and set the header image– that works fine. But, that same image appears on all of the other 3 pages. I don’t want that as each page needs a custom header image that reflects the content of that page.

    I thought “Featured Image” for each page would do what I want, but even after trying that on different WP sites and different browsers, it obviously doesn’t work that way. Or, I’m just not doing it right.

    Here’s one simple draft site that I was just testing. Still very much under construction, but hopefully shows what I’m seeing.

    How do I get a different header image to appear on each of these pages?

    Ah okay, no page-specific headers is not part of that theme. It’s possible to modify the theme to do that, or you could look for a theme that has that or try a plugin. But the other thing is that it appears that you’ve modified the twentytwelve theme files?? You really don’t want to do that – your changes will be overwritten when WP is updated and it’s also crucial to have a clean copy of the default theme for troubleshooting purposes. Instead changes should be made using a Child Theme – see:

    >>…It’s possible to modify the theme to do that, or you could look for a theme that has that or try a plugin


    Appreciate the input. Hard for me to imagine that anyone would want the exact same header image on every page so I just figured there must be a way.

    So what’s the purpose of a featured image option when editing a secondary page? It lets you choose an image and it seems to load, but doesn’t appear anywhere that I can find.

    Good advice re. the Child Theme route and in fact that’s what I’m working with here. I made “twentytwelve2” and copied the base stylesheet there along with any files that I’m changing. Comforting to know that I can always go back if I mess something up. Hey, at least I seem to be doing something right.

    Thanks again.

    Hi, I use the same theme and have played around with featured images.

    Featured images display at the top right of the content section of a page, below the header.

    So I don’t think that will suit your needs if you are trying to modify header images.

    I checked my twentytwelve theme and you can only select ONE header image.

    HOWEVER, the twentyeleven theme comes with the ability to use multiple header images, which are shuffled automatically.

    If you need a specific header image per page then this will not help.

    But if you dont mind random header images then this will do the trick.

    The twentyeleven theme comes with the current WP version so give that a try.

    The twentyeleven theme allows you to select using 8 different header images that come wiht the theme.

    I am sure that the header images can be replaced with your own somehow.

    This seems to be described here

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Featured image on page not possible??’ is closed to new replies.