WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Featured Image of Post Not Showing Up When Publicized to Facebook

[Resolved] Featured Image of Post Not Showing Up When Publicized to Facebook

  • daringfemme

    @daringfemme

    First a compliment: Jetpack is awesome!

    I am running WordPress using the Responsive theme on a Go Daddy hosted site. When I publicize a post to the Facebook fan page, the featured image does not display on the FB fan page post. Any ideas to troubleshoot this?

    Thanks in advance!

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 78 total)
  • I’m seeing the same behavior.

    Even forcing Facebook to refresh their cache for the shared URL doesn’t make the image show up.

    Sample FB post without image:

    Posted by Caustic Soda on Monday, November 12, 2012

    mandozz

    @mandozz

    I’ve got the same problem.

    Tried to manually (copy + paste) share the link with Facebook, and the image showed up without any problems.

    DanielNest

    @danielnest

    Having exactly the same issue. Publicize doesn’t seem to pull the “featured image”. Posts without other images show up as blank. Posts with other images show those, instead of the Featured Image.

    FYI, when I share the page using sharing buttons or directly by pasting it the “Featured Image” is correctly shown. I am using the “WP Facebook Open Graph protocol” and it takes care of things beautifully.

    It’s only the “Publicize” sharing that doesn’t work.

    This is a fantastic new feature and I sincerely hope it can be resolved.

    kpopremix

    @kpopremix

    I have the same issue as well. It does not show, I think we will have to wait for the WP to fix that.

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    Thanks for your reports!

    When checking the posts’ sourcecode on your site, could you copy here the og:image meta tags you see in the code, or give us a link to one of these posts?

    nicktomkinson

    @nicktomkinson

    DanielNest

    @danielnest

    Hi Jeremy,

    Each of my posts has a 150×150 Featured Image, here’s the latest:

    http://nest-expressed.com/2012/11/how-to-write-a-scam-letter/

    I have WP Facebook Open Graph to take care of things and the Featured Image always renders fine when using sharing buttons or just sharing the link directly.

    Publicize is so far the only tool that doesn’t seem to capture Featured Image.

    Daniel

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @daniel Thanks for these details. I had a look at your post, and while the image is indeed available in WP Facebook Open Graph’s meta tags, it’s not available in Jetpack Open Graph tags.

    Could you let me know how you set this image as the Featured Image for your post? Did you upload the image in your post, and set it as Featured Image thanks to the module at the bottom right of the Edit Post area?

    DanielNest

    @danielnest

    Spot on. I’ve used the regular WordPress functionality.

    1) Clicked on “Set Featured Image” at the right hand panel
    2) Uploaded image from Computer to the Gallery
    3) Clicked “Use as featured image” at the bottom

    Hope that helps!

    elirnerak

    @karenrilegmailcom

    I was having this problem and I solved it– at least for my site. I use theme Weaver ii Pro theme, which has an option in the advanced settings to select a “preferred image for Facebook.” I’d uploaded a screenshot of the site there to control the featured image. But that seemed to override the Jetpack share settings. When I deleted the link to the url for the preferred image for Facebook, the featured image suddenly showed up correctly. Hope this turns out to be useful for others.

    sanford neon

    @sanford-neon

    Same issue for me… Hatch theme w/ jetpack.. publisher only uses image in post.. not featured image or images in gallery in post… Help us please… lightfantasticneon.com http://www.facebook.com/pages/Light-Fantastic-Neon/190466577649008

    We have the same problem on http://www.family-faces.de its hard, pls help us.

    lukeratto

    @lukeratto

    same problem here. Was using a Wordbooker, worked great, but in a an effort to dump uneeded plugins and use more JetPack plugins I began using Publize, but it’s not showing the Featured image or the header image.

    nicktomkinson

    @nicktomkinson

    @jeremy – do you have an update on when a fix may be available please?

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    Unfortunately, I wasn’t able to reproduce the issue so far.

    I noticed that you already use another plugin to add Facebook Open Graph Meta tags to your posts. Could you try to disable this plugin, and see if that helps? Jetpack now automatically includes Open Graph Meta Tags so you shouldn’t need any other plugin.

Viewing 15 replies - 1 through 15 (of 78 total)
  • The topic ‘[Resolved] Featured Image of Post Not Showing Up When Publicized to Facebook’ is closed to new replies.
Skip to toolbar