WordPress.org

Forums

User Submitted Posts
[resolved] Featured Image not working (12 posts)

  1. derick1981
    Member
    Posted 1 year ago #

    Hello, I can not get the featured image to work. I have tried many of the previous things recommended (code snippets). My theme does support Featured images. Please help. Thank you very much and nice plug-in.

    http://loosegroupclub.com

    go to post your own page on the left to see USP

    http://wordpress.org/plugins/user-submitted-posts/

  2. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I am the plugin author and I've posted a technique for this that works great:

    http://wp-mix.com/set-attachment-featured-image/

  3. derick1981
    Member
    Posted 1 year ago #

    Thank you Jeff, I have tried both of these methods three times each with no luck. I would greatly appreciate some more guidance.

    Thank you,

    Derick

  4. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    Sure, which step is giving you problems?

  5. derick1981
    Member
    Posted 1 year ago #

    I have installed it fine and can get all of the fields to work just the featured image will not show up. I have tried both methods of inserting the code and it is still not working. Not sure what I am missing...

    http://loosegroupclub.com/

    you can go to post your own page on the left to see the USP form.

  6. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like something is interfering, perhaps another plugin?

  7. derick1981
    Member
    Posted 1 year ago #

    I have deactivated every plugin except USP. Still I can not get the featured image to show. Any other suggestions?

  8. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm.. are you sure that images are successfully uploaded? They will be displayed as featured images only if they exist on the server..

  9. derick1981
    Member
    Posted 1 year ago #

    Yes, they are showing in the post. But not on the home page where the featured images should show.

    http://loosegroupclub.com/asdfasd/

  10. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    If they're showing for the single-view of the post, then it's working fine. It means that you should look at your theme's single.php file (and/or functions.php) and then apply whatever code is working to your home page template (e.g., index.php, home.php, et al).

  11. derick1981
    Member
    Posted 1 year ago #

    Yeah I think that is beyond my understanding.

  12. Jeff Starr
    Member
    Plugin Author

    Posted 1 year ago #

    Just to follow-up with this, I'm currently working on a Pro version of USP that will make it much easier to display submitted content. News will be announced in the free version of the plugin's settings page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • User Submitted Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic