WordPress.org

Support

Support » Plugins and Hacks » CSV Import for WordPress » [Resolved] Featured Image not working

[Resolved] Featured Image not working

  • Thank you for sharing this plugin. It is really nice and it works great!

    There’s one thing I cannot figure out. I cannot get the feature image import right. I have checked the issues discussed so far but still I cannot get it to work.

    I am using “Hatch” theme (which uses feature images). But I also tried to do an import with another theme with no results. Everything shows but not the feature image.

    I have put the images in the the uploads/wp-content directory. (I have set the permission to 777). I am not using the year/month folders. I can see the images when I approach the urls from the csv in my the browser.

    I have also tried to import from another folder on my server /images but with no luck. I have noticed there is a ultimate_importer folder inside the uploads folder. Should I do anything with that?

    Any suggestions or ideas are very welcome! I hope I can get this to work!

    http://wordpress.org/plugins/wp-ultimate-csv-importer/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author smackcoders

    @smackcoders

    How you mention featured image in your csv? It should be externally or internally hosted image and should be a valid full url path to the image. Ensure that the image exist at that location or else the import breaks with an error.

    I tried both using the full url internally and externally. Both with no result. When I approach the full url I can see the image. In addition I don’t see any error messages, the feature image just doesn’t show in backend or frontend. The url I use in the csv looks like this:

    http://test.mysitename.com/wp-content/uploads/00001_image.jpg

    I have tried the import with several different themes that have feature images still no luck.

    Does anyone else have this problem? I really would like to use this plugin. All suggestions and ideas are very welcome. Thanks in advance!

    Plugin Author smackcoders

    @smackcoders

    Strange. Are you doing it in right way. For testing try with this url http://upload.wikimedia.org/wikipedia/commons/thumb/4/4d/Pierre-Auguste_Renoir_007.jpg/300px-Pierre-Auguste_Renoir_007.jpg

    Ensure that the csv is in UTF-8 format. Also check the folder permission is writable.

    I have made a test csv with your provided image url. The csv looks like this now.

    post_title,post_content,post_excerpt,post_date,post_category,post_tag,post_author,featured_image,post_slug,post_parent,post_status,Keywords
    Lorem Ipsum,Dolor Sit, ,,, ,,http://upload.wikimedia.org/wikipedia/commons/thumb/4/4d/Pierre-Auguste_Renoir_007.jpg/300px-Pierre-Auguste_Renoir_007.jpg,,,,

    I checked the UTF-8 settings and that is okay. The folder permissions are:
    writable for wp-content and wp-content/uploads.

    In the uploads folder there is another folder ultimate_importer what should I do with that? It is not mentioned in the installation instructions. (I have made it also writable for this test)

    When I upload and map the csv. I get no error but no featured images either.

    Hi fresh99. I am having the same problem. No errors and no featured image. Does anyone have a solution to this?

    Thanks

    Hi all,

    I’m having a problem importing images using WP Ultimate CSV Importer. No matter what I try, the text will be imported from the CSV but never the images. No error is shown, the images just aren’t there I have included my .csv file (perhaps I am going wrong somewhere with this).

    Any help at all would be much appreciated. Thanks in advance

    https://docs.google.com/file/d/0Bx-E4Y4EDrprVVJaRE1NTlFTUTA/edit?usp=sharing

    (you may not be able to view this in Google doc as it is .csv but you can download it).

    Plugin Author smackcoders

    @smackcoders

    @fresh99,

    I can import your csv without any issues in http://demo.smackcoders.com/demowptwo/wp-admin/post.php?post=1000&action=edit. You can refer this post created from importing your csv. Or else you can test your csv her in live demo of wp ultimste csv importer

    You need find what is going with your imports instead of simply guessing?

    Plugin Author smackcoders

    @smackcoders

    @delaney101,
    Thanks for starting your own thread and i have replied there. You should use some supporting image formats in you csv

    I uploaded the same .csv file to the demo site and yes it is working excellent.
    http://demo.smackcoders.com/demowptwo/lorem-ipsum-3/

    I have noticed that the demo site is not updated to WordPress 3.6 and my installation is. Other than that I am out of guesses why it is not working on my server.

    Plugin Author smackcoders

    @smackcoders

    No, we have not updated the demo instance to 3.6. But we have tested with WP 3.6. It should work. Check that the image is uploading to your uploads/2013/09 folder.

    Nothing is uploading during the import process. When I put the images in that wp-content/2013/09 folder (and set the right permissions for those folders) and put the right urls in the csv still nothing happens.

    I have tested my theme and the plugin locally using Xamp and then it works perfect. So the problem occurs on the server side. Are there any server settings I should check? Other than the permissions of the upload folder?

    Plugin Author smackcoders

    @smackcoders

    May be issue with image handling. But if you can import images manually, then it should be issue with importing external images. Get hosting support to solve this.

    I finally got this to work. I contacted my hosting and the problem was caused due to the allow_url_fopen option being disabled in my php.ini file. Once I enabled it. It works perfect. Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Featured Image not working’ is closed to new replies.
Skip to toolbar