Support » Fixing WordPress » Featured image not showing up after 3.8 upgrade

  • The media library is pointing to this location now for featured images and any media references. My gallery plugin is working fine so I think this has something to do with the upgrade of WordPress 3.8.

    <img src=”” alt=”xxxx” width=”595″ height=”187″>

    Any ideas on fixing this situation?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder and wp-config.php & root .htaccess files – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    same problem here, no plugin enabled, but no featured image box editing post… WP 3.8

    @munger41: It is considered impolite to interrupt another poster’s ongoing thread unless you are posting a solution or suggestion. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    Was there any resolution with this issue? I am encountering the same issue.



    Forum Moderator

    @chuckie – you too, need to start your own thread if you need help.

    register your custom size in functions.php
    add_image_size(‘my_feature_image’, 450, 250, true);
    and call it in yout theme
    <?php the_post_thumbnail(‘my_feature_image’); ?>

    Hi All – i reverted back to the older version of WordPress and that resolved this issue. It looks like Media and my plugin called nextGEN gallery did not work properly when I tried to replace the images.

    I’m having the same issue currently. The Featured Image option is available, but it’s not updating the image when I save the post. Are there some new permissions settings going on in 3.8?



    Forum Moderator

    Does this happen in a default theme with ALL plugins deactivated? Have you checked the file permissions on the server?

    If you need additional help, please also start your own thread as per the forum guidelines –

    Yup, I deactivated all plugins and used a default theme and it displayed the correct image. Ok, looks like I get to start a new thread…

    hi i have upgraded my wordpress site to 3.8 i lost all my images which inserted to my post all i get is broken images when i look media gallery i see the images but is grayed out. i have tried everything like deactivating my pluging and activating one by one no solution.

    when i write new post i can insert a new image the problem is uploader isn’t displaying the image is attaching to the post my logo default image can any one help please.

    Make sure you have the following in your functions.php file:

    add_theme_support( 'post-thumbnails' );

    that was exactly what i needed. because i’m using a completely outdated theme.. thanks!



    Hey Guys I found a fix that worked for me. If you have Jetpack installed go to the “photon” option and deactivate it, done like dinner !



    Actually, after the updates, I simply deleted the image from the library, uploaded again and insert them into the original pages. And the feature images are showing.
    I haven’t did any code modification.
    Hope this helps!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Featured image not showing up after 3.8 upgrade’ is closed to new replies.