WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » Featured Image Not Showing

Featured Image Not Showing

Viewing 9 replies - 1 through 9 (of 9 total)
  • Can you provide a link? Did you use the shop page provided by WC or change it?

    I’m a bit confused. What do you mean by you have F.I. manually set on page and show post title disabled?

    Here’s the link …

    http://steelbookreview.com/shop/

    The page is the default Shop page.

    In the page’s settings, under Page Options -> Blog Single Page, I have Show Post Title set to No and Show Featured Image Before post set to yes. Yet the post’s title still shows and the featured image does not.

    I went to your site and see images in both the shop, single product and lightbox. So where are you not seeing the image? You prolly know this, but the feature image is what’s shown. If you’re trying to use 2 different images for product and feature, then I cannot help you with that as I haven’t tried it.

    I’m not clear where you have the Title that you don’t want. All I see is titles to movies on both shop and single product page.

    As to the Page Options, that must be in your theme, as I don’t see them anywhere in WC. Although if you find what the title is set under using Firebug or other, you can try to put display: none; in your custom.css or childtheme.css

    Sorry I couldn’t be more help 🙁

    Thanks so much for looking into it. Here are two pics which show the settings I’m taking about.

    https://lh4.googleusercontent.com/-hMgQTibhc40/UxYSXZNdxzI/AAAAAAAACBc/B4u1taNhu28/w1702-h903-no/stfi.jpg

    https://lh5.googleusercontent.com/-HGlf46I9UWM/UxYSXcLMDrI/AAAAAAAACBI/-TXOBMvMsgI/w799-h690-no/srfipt.jpg

    BTW, this is just for the Shop’s main page, not the individual product pages. Those are just how I want them to be.

    Maybe it is an issue with my theme?

    Ah now I understand one thing. lol The page options are not inherent to WC, but your theme. Perhaps ask about this issue on their support page?

    As to the Featured image, not sure what you are wanting instead of what you have. I see a moving slider of featured products and below that thumbnails of your products listed which cover 3 pages. So that’s not what you want on your Shop page? What would you like?

    I don’t think you can to set a featured image for the shop page. If you did get it to work, I think it would remove all the product images. Certainly don’t quote me on that though.

    I’m working on a banner that I want at the top of the Shop page above the slider and products. Check out the main picture on this review page … http://steelbookreview.com/aliens-zavvi-blu-ray-steelbook-review/

    The top-most picture is the ‘Featured Image’. I’ll check in with my theme’s support. Could be an issue there.

    Oh! Well to set that you would do it in your site header/banner/logo settings. Or do you want it to be different from your other pages? Even then you wouldn’t change that within the Shop page itself. 🙂

    No, no, I want the banner to be at the top of the page, not in the header. 🙂 I’ve opened a support ticket with my theme’s people. Will report back if it is a bug on their end.

    My apologies for not understanding exactly what you wanted. If you want to put images on the shop page above everything, try inserting them above the code for the moving slider. Hope this now works for you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Featured Image Not Showing’ is closed to new replies.
Skip to toolbar