Support » Theme: Customizr » Featured image not showing

  • Hi, i’m trying to show a featured image in some pages of my site, i go in the page section, edit my page, set the featured image (and the editor shows it in thumbnail), update the page, but the featured image isn’t showed.
    How can i do?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi,
    In Customizr, the page featured images are used only for the featured page (see front page options in customizer screen).
    You will have include the image in your page to display it.



    Featured images are showing up on some Customizr pages, but not on others, and not where I set the featured image. See So I don’t get anything on the home page for those pages. It looks terrible. And it doesn’t show up next to my titles, ever. I deactivated all plugins, nothing. I’ve tried setting feature images of course. Featured image image does not show when I press “set featured image.” I have reduced imaged to the 270×250 size. Heeeeellllp! I’d really appreciate any insights–am trying to make sense of other posts. Maybe there is a plugin fix for this? Thanks, Doug

    Pls start a new Topic next time.

    Are you expecting the 3 x FIs on the Front Page? Looks like you’ve not set them in Customiz’it!>Front Page>Featured Pages Options>Show Images= ticked?

    Which other Pages are you trying to get Images displayed?



    Thanks for the reply. Unfortunately it doesn’t appear to be so simple. I had had the box ticked, but I got one non-featured image pulled from the page to show–not the featured image from that page–and blank space or white space in the other two features–so it looked messed up. So I unticked the box because having only one image show looked sloppy.

    And on the related pages, I get an icon next to the title, not a featured image.

    Any thoughts would be great. Thanks, Doug

    Looks like you’re using the Core Theme 1.1.10, not a Child Theme?

    My first instinct would be to check for plugin conflicts but you say you’ve done this. In the past, there have been problems with NexGen and WooCommerce but I’m not aware of any known issues with this latest release.

    I’d suggest deactivating those 2 plugins (or even all plugins), reinstalling the 1.1.10 theme and then test the basic FIs before you reactivate plugins. This will eliminate any other potential problems as if you have the same problems with just the core Theme then we need to know that.

    Check that you have retina support enabled (in Customiz’it) and re-upload the image.

    I’ve just purchased and installed Featured Pages Unlimited. Great tool, however, my 3 x FIs aren’t showing across the top of the front page either. All FIs are set within (in my case) Posts. The images show on the blog excerpts.

    In Customiz’It, under Featured pages, Display Thumbnails is checked, and all boxes are clicked under the Images section.

    I don’t see any plugins that could be causing them not to show. I’m not using a child theme. I’ve done many customizations using the css box, so I don’t really want to update the core theme.

    Any suggestions?


    Wanna try to regenerate your thumbnails with this tool?

    Also, if you changed just the custom css in the box, and you’re afraid to lose it, why don’t you copy and paste it in a simple text file. Then make the theme upgrade, and if that box is empty you can always re-fill it with what you saved..

    Thanks d4z. I had initially deactivated the regenerate thumbs plugin (had it previously installed).

    I’ve successfully updated the theme without losing customization. I’ve deactivated and re-activated the regen thumbs plugin. I’ve deactivated any plugin that may have been interfering (even jetpack).

    Still no featured images showing on the front page. Re-checked the Customiz’It too to make sure all necessary boxes were checked.

    the site is:

    any other ideas? thanks.

    Hmm sorry, I thought you had the “retina-bug” issue, because this topic talks about that.
    My fault, I didn’t check your page before, you have this in your custom.css

    .home .thumb-wrapper {
        display: none;

    Remove it and you’re done.
    Probably there was a reason before…

    Hey but now you have no fear to make an update anymore, it’s been worthwhile then 😀

    wow that was easy! That was it. Don’t know why that code was in my custom css (and I didn’t see it).

    Yes, NO FEAR!

    Thanks d4z!


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Featured image not showing’ is closed to new replies.