Support » Plugin: Post to Google My Business » Featured image not sharing

  • Resolved aperire

    (@aperire)


    In my posts on my website, I include both text and image, but in the Google post the image is missing. There are no error messages. Any idea how to solve this? Thanks,  Katsumi.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Koen Reus

    (@koen12344)

    Hi Katsumi,

    Do you have “Use Featured Image as post image” enabled in the Advanced post settings?

    https://i.imgur.com/YAz2shA.png

    If you’re talking about images that are within the content of the post, if you enable “Fetch image from post content” it should pick up the first available image from the post content and use that as the image for the GMB post.

    ~ Koen

    Thread Starter aperire

    (@aperire)

    Hi Koen,
    Thank you for reply!
    In the case of current WordPress, “Use Featured Image as post image” is correct because I post after →, isn’t it? →https://i.imgur.com/vd9Yv3O.png

    Then it will look like an arrow.
    My Post→https://i.imgur.com/lq1sNZf.png

    Then,GMB →https://i.imgur.com/pRYKiuC.png
    Thanks,  Katsumi.

    Plugin Contributor Koen Reus

    (@koen12344)

    Yes it should work fine with the default featured image in the new block editor.

    Do you have “Use Featured Image as post image” enabled in the auto-post template? (Post to GMB > Settings > Auto-post settings). And “Fetch image from post” turned off? The latter might throw it off if it is enabled and there are no images in the post content.

    If you create a manual post through the Post to GMB section in the block editor like this: https://i.imgur.com/wD374z8.png

    Does it pick up the featured image then?

    ~ Koen

    Thread Starter aperire

    (@aperire)

    Hi Koen,
    Thank you for reply!
    I can’t find the route(Post to GMB > Settings > Auto-post settings) you specify. When I open “New Post” in the management screen of GMB itself, a screen similar to the image you specified appears, but there is no essential button at the bottom.→ https://i.imgur.com/YNs3X1J.pngThere are no items that lead to auto post settings in the settings of the WP posting screen. →https://i.imgur.com/FCzO5UF.png       →https://i.imgur.com/w570vdZ.png
    Even if I search for a site that uses all of Japan’s “wp google my business auto publish”, I can’t find the photo you specify, so the item itself that guides you to Japan’s (possibly other countries) Image settings(Advanced post settings) is It may not be there. I would be grateful if you could tell me any information.

    Thanks,  Katsumi.

    Plugin Contributor Koen Reus

    (@koen12344)

    Hi Katsumi,

    Looks like you’re using a different plugin by a fellow developer “WP Google My Business Auto Publish”, and not my plugin Post to Google My Business.

    I’m sure they will be able to assist you in their support section!

    Feel free to try my plugin and see if it meets your requirements.

    ~ Koen

    Thread Starter aperire

    (@aperire)

    Oops, I’m sorry! It seems that when I searched, it was transitioning to your site. But I was lucky enough to use your plugin and everything I wanted was solved! thanks so much!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.