Support » Plugin: Broadcast » Featured Image Not Broadcasting

  • sheabaker

    (@sheabaker)


    Just updated the plugin to version 28.

    When I publish a new post, the featured image does not copy correctly to the child site. The featured image show properly on the main site, but on the child site it is missing (404 Not Found). The media library on the child site shows a record of the image, but the image itself is missing.

    How can I resolve?

    https://wordpress.org/plugins/threewp-broadcast/

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author edward_plainview

    (@edward_plainview)

    You aren’t using a CDN plugin, are you?

    At any rate, you’ll have to supply me with a broadcast debug dump so that I can see what Broadcast is trying to do.

    sheabaker

    (@sheabaker)

    Hello,

    No, not using a CDN plugin, but the site is hosted with WP Engine. The broadcasting has been working correctly on the site for 2+ years now.

    Here is the debug log from when I uploaded a feature image and saved/broadcasted the post:
    http://northernclover.staging.wpengine.com/wp-admin/wp-content/plugins/threewp-broadcast/ThreeWP_Broadcast.php.f3ce7e87.debug.php

    Plugin Author edward_plainview

    (@edward_plainview)

    Looks good to me.

    2016-01-29 14:21:58 ThreeWP_Broadcast: Handling post thumbnail for post 2406. Thumbnail ID is now 2411

    Media ID 2411 should be 2016/01/barrett.jpg, file size 1054144 bytes.

    Does it not exist on disk or in the media library?

    Plugin Author edward_plainview

    (@edward_plainview)

    You should be able to find the file here, according to the debug dump:

    /nas/content/staging/northernclover/wp-content/uploads/sites/3/2016/01/barrett.jpg

    sheabaker

    (@sheabaker)

    Parent Site Has image: http://northernclover.staging.wpengine.com/products/product-title-name-of-product-only/

    Child Site Does Not: http://northernclover.staging.wpengine.com/sites/products/product-title-name-of-product-only/

    Child post says: http://northernclover.wpengine.com/sites/wp-content/uploads/sites/3/2016/01/barrett.jpg Failed to load resource: the server responded with a status of 404 (Not Found)

    Child media library shows a record for the image, but the image itself is missing (404).

    Plugin Author edward_plainview

    (@edward_plainview)

    Well, I’m kinda stumped. The debug log says that the image was copied correctly (the file size check confirms that) and the image was correctly inserted inte the db (as per the new media ID).

    How do the files look on disk? You don’t have any plugins active that could interfere with media file creation?

    sheabaker

    (@sheabaker)

    I’m now thinking maybe this has something to do with WordPress itself – maybe the rewrite rules.

    I can go in via ftp and see the file in the location it is supposed to be. But WordPress won’t show it. I’m checking it against the older image paths that are working and they seem to be the same structure, but something must be different.

    I appreciate your help.

    miramayhem

    (@miramayhem)

    I have a similar problem.
    The images from the broadcasted post (a product within WooCommerce) are correctly copied to the target directory, and the entry in the database has the correct link. If I copy the url directly to the browsers’ addressbar, the image is shown. But not when inside WP. Not in the media-library and not in the child post.

    The problem is however not consistent, it works for some post/images but nothing obvious in common for the ones working.

    I tried to remove the broadcast and selected “Delete child” – the child disappeared from the subsite. I tried to broadcast it back, but to no avail.

    I’m also inclined towards some WP internal issue. Another plugin causing conflict, but how do I find out which one? And if so, how come the issue isn’t consistent?

    Any help is appreciated.
    sheabaker: you didn’t find a solution?

    Parent (broadcasted from):
    http://no-sir.com/designers/twin-within/

    Child (broadcasted to):
    http://no-sir.com/sv/designers/twin-within/

    Plugin Author edward_plainview

    (@edward_plainview)

    I suppose you’ve also checked your debug log, seen that the attachment was correctly copied (the file sizes matching), and the references to the old media ID replaced with the new ID…

    … and yet it still doesn’t work?

    The biggest problem, as you say, is the inconsistency. If you could figure out a way to make it not work consistently, we could try to locate the problem.

    What plugins do you have active, anyways? And who is your web host? WP Engine?

    miramayhem

    (@miramayhem)

    Thank you for responding!
    I haven’t checked the debug log. I connect to the server with ssh and located the files through the filesystem. The posts I examined with phpmyadmin. I tried to activet wp_debug, but I got ugly output on the live site, so I had to turn it off. (I’m currently working on removing these Notifications and Warnings).

    There is a whole bunch of plugins active:

    • Advanced Custom Fields Pro
    • Advanced Custom Fields: Image Crop Add-on
    • Akismet
    • Contact Form 7
    • Duplicate Post
    • Envato WordPress Toolkit
    • Revolution Slider
    • Simple Image Sizes
    • ThreeWP Broadcast
    • Velvet Blues Update URLs
    • WooCommerce
    • WooCommerce Header Category Image
    • WooCommerce Klarna Gateway
    • WooCommerce Table Rate Shipping
    • WordPress Importer
    • WordPress SEO
    • WPBakery Visual Composer

    The web host is Inviso (a Swedish web host)

    Plugin Author edward_plainview

    (@edward_plainview)

    The only thing that really strikes me as a potential source of conflict is Akismet, which is a CDN plugin, yes?

    miramayhem

    (@miramayhem)

    No:
    “Akismet is quite possibly the best way in the world to protect your blog from comment and trackback spam”

    No CDN-related plugin afaik.

    There was, however, some kind of CDN when the site was hosted on a development-server. I wasn’t involved in the project at that early stage, though.

    Plugin Author edward_plainview

    (@edward_plainview)

    Oh. Then I’m not sure.

    Simple Image Sizes? Are the specified sizes different on the two blogs? (not that I know what the plugin does…)

    Anything that is related to images or files I’d look at.

    erincampbell

    (@erincampbell)

    Hi,

    I have recently updated the WordPress to 4.4.2 and also changed hosting and I have a similar issue where a custom post type is broadcasted correctly, as are all custom fields, except for the images. The images themselves are copied across to the child’s library and I can view them correctly, however they do not seem to be linking up so when editing the custom post type, it has no image shown.

    I am also using the Advanced Custom fields plugin, if that helps.

    Thanks,

    Plugin Author edward_plainview

    (@edward_plainview)

    > I am also using the Advanced Custom fields plugin, if that helps.

    It does. Image IDs have to be specially handled during broadcasting, which in this case is done using the ACF Broadcast plugin. See here: https://plainviewplugins.com/threewp-broadcast-premium-pack/advanced-custom-fields-broadcast-plugin/

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Featured Image Not Broadcasting’ is closed to new replies.